summaryrefslogtreecommitdiffstats
path: root/package/libs/cyassl
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-04-01 10:42:28 +0000
committerJohn Crispin <john@openwrt.org>2015-04-01 10:42:28 +0000
commitb233fdcfa2c70594dfb05cdea021cda3684b35a3 (patch)
tree6a31de0947749f9cbfa3162fe4685796c059186c /package/libs/cyassl
parenteeff1f0a12636d80450a50a491af5aa5cb30e6ec (diff)
downloadmaster-31e0f0ae-b233fdcfa2c70594dfb05cdea021cda3684b35a3.tar.gz
master-31e0f0ae-b233fdcfa2c70594dfb05cdea021cda3684b35a3.tar.bz2
master-31e0f0ae-b233fdcfa2c70594dfb05cdea021cda3684b35a3.zip
cyassl: add support for SSL_set_tlsext_host_name
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 45215
Diffstat (limited to 'package/libs/cyassl')
-rw-r--r--package/libs/cyassl/Makefile2
-rw-r--r--package/libs/cyassl/patches/300-SSL_set_tlsext_host_name.patch10
2 files changed, 12 insertions, 0 deletions
diff --git a/package/libs/cyassl/Makefile b/package/libs/cyassl/Makefile
index a748adbb6b..2be0198c64 100644
--- a/package/libs/cyassl/Makefile
+++ b/package/libs/cyassl/Makefile
@@ -40,6 +40,8 @@ TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
--without-zlib \
--enable-singlethreaded \
+ --enable-opensslextra \
+ --enable-sni \
--disable-examples
define Build/InstallDev
diff --git a/package/libs/cyassl/patches/300-SSL_set_tlsext_host_name.patch b/package/libs/cyassl/patches/300-SSL_set_tlsext_host_name.patch
new file mode 100644
index 0000000000..d81e416180
--- /dev/null
+++ b/package/libs/cyassl/patches/300-SSL_set_tlsext_host_name.patch
@@ -0,0 +1,10 @@
+--- a/cyassl/openssl/ssl.h
++++ b/cyassl/openssl/ssl.h
+@@ -372,6 +373,7 @@
+ #define SSL_CTX_get_ex_new_index CyaSSL_CTX_get_ex_new_index
+
+
++#define SSL_set_tlsext_host_name(x, y) CyaSSL_UseSNI(x, CYASSL_SNI_HOST_NAME, y, strlen(y))
+
+ #ifdef __cplusplus
+ } /* extern "C" */