summaryrefslogtreecommitdiffstats
path: root/package/libs/cyassl
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2015-07-03 23:20:01 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2015-07-03 23:20:01 +0000
commit9177e160987af4939b65b865adc1be916e28b997 (patch)
treedf5fbf7ad66437273f28e2eded244c4eb9f845b6 /package/libs/cyassl
parentb5b630ae3884ce8f4b416cb06a91ebc002ce83ed (diff)
downloadmaster-31e0f0ae-9177e160987af4939b65b865adc1be916e28b997.tar.gz
master-31e0f0ae-9177e160987af4939b65b865adc1be916e28b997.tar.bz2
master-31e0f0ae-9177e160987af4939b65b865adc1be916e28b997.zip
cyassl: version bump to 3.4.6
This patch introduces a new build error into coova-chilli, but coova-chilli already fails to build even without it anyway. CyaSSL is now called wolfSSL, and all the API's have been renamed, and backward-compatibility headers added. Signed-off-by: Daniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 46167
Diffstat (limited to 'package/libs/cyassl')
-rw-r--r--package/libs/cyassl/Makefile22
-rw-r--r--package/libs/cyassl/patches/200-SSL_accept-handle-hello-garbage.patch2
-rw-r--r--package/libs/cyassl/patches/300-SSL_set_tlsext_host_name.patch10
-rw-r--r--package/libs/cyassl/patches/400-additional_compatibility.patch15
4 files changed, 37 insertions, 12 deletions
diff --git a/package/libs/cyassl/Makefile b/package/libs/cyassl/Makefile
index c3361eb64f..72b98e1d73 100644
--- a/package/libs/cyassl/Makefile
+++ b/package/libs/cyassl/Makefile
@@ -7,13 +7,13 @@
include $(TOPDIR)/rules.mk
-PKG_NAME:=cyassl
-PKG_VERSION:=3.3.0
-PKG_RELEASE:=2
+PKG_NAME:=wolfssl
+PKG_VERSION:=3.4.6
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
PKG_SOURCE_URL:=http://www.yassl.com/
-PKG_MD5SUM:=0303eb0f2f9065a1207d9104ab0eba7c
+PKG_MD5SUM:=0410b3841588d635e9ecacb2d42c38f5
PKG_FIXUP:=libtool
PKG_INSTALL:=1
@@ -45,17 +45,27 @@ CONFIGURE_ARGS += \
--enable-ecc \
--disable-examples
+ifneq ($(CONFIG_TARGET_x86),)
+ CONFIGURE_ARGS += --enable-intelasm
+endif
+ifneq ($(CONFIG_TARGET_x86_64),)
+ CONFIGURE_ARGS += --enable-intelasm
+endif
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.{so*,la} $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libwolfssl.{so*,la} $(1)/usr/lib/
+ ln -s libwolfssl.so $(1)/usr/lib/libcyassl.so
+ ln -s libwolfssl.la $(1)/usr/lib/libcyassl.la
endef
define Package/libcyassl/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libwolfssl.so* $(1)/usr/lib/
+ ln -s libwolfssl.so $(1)/usr/lib/libcyassl.so
endef
$(eval $(call BuildPackage,libcyassl))
diff --git a/package/libs/cyassl/patches/200-SSL_accept-handle-hello-garbage.patch b/package/libs/cyassl/patches/200-SSL_accept-handle-hello-garbage.patch
index 5463cb0cf9..4e2c540bd8 100644
--- a/package/libs/cyassl/patches/200-SSL_accept-handle-hello-garbage.patch
+++ b/package/libs/cyassl/patches/200-SSL_accept-handle-hello-garbage.patch
@@ -1,6 +1,6 @@
--- a/src/internal.c
+++ b/src/internal.c
-@@ -6037,6 +6037,10 @@ int ProcessReply(CYASSL* ssl)
+@@ -6353,6 +6353,10 @@ int ProcessReply(CYASSL* ssl)
b1 =
ssl->buffers.inputBuffer.buffer[ssl->buffers.inputBuffer.idx++];
ssl->curSize = (word16)(((b0 & 0x7f) << 8) | b1);
diff --git a/package/libs/cyassl/patches/300-SSL_set_tlsext_host_name.patch b/package/libs/cyassl/patches/300-SSL_set_tlsext_host_name.patch
index d81e416180..5bccb05133 100644
--- a/package/libs/cyassl/patches/300-SSL_set_tlsext_host_name.patch
+++ b/package/libs/cyassl/patches/300-SSL_set_tlsext_host_name.patch
@@ -1,10 +1,10 @@
---- a/cyassl/openssl/ssl.h
-+++ b/cyassl/openssl/ssl.h
-@@ -372,6 +373,7 @@
- #define SSL_CTX_get_ex_new_index CyaSSL_CTX_get_ex_new_index
+--- a/wolfssl/openssl/ssl.h
++++ b/wolfssl/openssl/ssl.h
+@@ -398,6 +398,7 @@
+ #define SSL_get_default_timeout(ctx) 500
-+#define SSL_set_tlsext_host_name(x, y) CyaSSL_UseSNI(x, CYASSL_SNI_HOST_NAME, y, strlen(y))
++#define SSL_set_tlsext_host_name(x, y) wolfSSL_UseSNI(x, WOLFSSL_SNI_HOST_NAME, y, strlen(y))
#ifdef __cplusplus
} /* extern "C" */
diff --git a/package/libs/cyassl/patches/400-additional_compatibility.patch b/package/libs/cyassl/patches/400-additional_compatibility.patch
new file mode 100644
index 0000000000..360fb148cf
--- /dev/null
+++ b/package/libs/cyassl/patches/400-additional_compatibility.patch
@@ -0,0 +1,15 @@
+--- a/cyassl/openssl/ssl.h 2015-02-25 13:04:52.000000000 -0800
++++ b/cyassl/openssl/ssl.h 2015-05-20 11:13:44.476628943 -0700
+@@ -25,3 +25,12 @@
+ */
+
++#ifndef CYASSL_OPENSSL_H_
++#define CYASSL_OPENSSL_H_
++
++#include <cyassl/ssl.h>
++#ifndef HAVE_SNI
++#undef CYASSL_SNI_HOST_NAME
++#endif
+ #include <wolfssl/openssl/ssl.h>
++
++#endif