summaryrefslogtreecommitdiffstats
path: root/package/libs/cyassl
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-10-30 13:19:48 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-10-30 13:19:48 +0000
commit5e8abac86fff7b612618acec2cff7eb5ac020bb0 (patch)
tree150425c99d38ba8884f86cbb4f8eac0f301ac9da /package/libs/cyassl
parentfdfc296aaff70746569c8382ae21b676d0d5c1b0 (diff)
downloadmaster-31e0f0ae-5e8abac86fff7b612618acec2cff7eb5ac020bb0.tar.gz
master-31e0f0ae-5e8abac86fff7b612618acec2cff7eb5ac020bb0.tar.bz2
master-31e0f0ae-5e8abac86fff7b612618acec2cff7eb5ac020bb0.zip
cyassl: upgrade to v2.8.0
Un-reverts the previous update commit and forward-ports the patch to improve legacy SSLv2 handshake handling. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 38609
Diffstat (limited to 'package/libs/cyassl')
-rw-r--r--package/libs/cyassl/Makefile13
-rw-r--r--package/libs/cyassl/patches/200-SSL_accept-handle-hello-garbage.patch6
2 files changed, 10 insertions, 9 deletions
diff --git a/package/libs/cyassl/Makefile b/package/libs/cyassl/Makefile
index 063e572166..df8335e800 100644
--- a/package/libs/cyassl/Makefile
+++ b/package/libs/cyassl/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cyassl
-PKG_VERSION:=1.6.5
-PKG_RELEASE:=2
+PKG_VERSION:=2.8.0
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
PKG_SOURCE_URL:=http://www.yassl.com/
-PKG_MD5SUM:=98c2c6350acf1d089756a1de9ccb9903
+PKG_MD5SUM:=7465d4815af90eff01095fa1b031ce09
PKG_FIXUP:=patch-libtool
PKG_INSTALL:=1
@@ -38,14 +38,15 @@ TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
--without-zlib \
- --enable-singleThreaded
+ --enable-singlethreaded \
+ --disable-examples
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.{a,so*,la} $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.{so*,la} $(1)/usr/lib/
endef
define Package/libcyassl/install
diff --git a/package/libs/cyassl/patches/200-SSL_accept-handle-hello-garbage.patch b/package/libs/cyassl/patches/200-SSL_accept-handle-hello-garbage.patch
index 4a6b8da67e..d46f549a5d 100644
--- a/package/libs/cyassl/patches/200-SSL_accept-handle-hello-garbage.patch
+++ b/package/libs/cyassl/patches/200-SSL_accept-handle-hello-garbage.patch
@@ -1,6 +1,6 @@
---- a/src/cyassl_int.c
-+++ b/src/cyassl_int.c
-@@ -1588,6 +1588,10 @@
+--- a/src/internal.c
++++ b/src/internal.c
+@@ -4622,6 +4622,10 @@
b1 =
ssl->buffers.inputBuffer.buffer[ssl->buffers.inputBuffer.idx++];
ssl->curSize = ((b0 & 0x7f) << 8) | b1;