summaryrefslogtreecommitdiffstats
path: root/package/libs/cyassl/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-10-29 09:53:48 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-10-29 09:53:48 +0000
commit8e2106488a812dbb316776940a3b552a31b88549 (patch)
treec49b945da7e46ba049138a88a082cf0dfa37326a /package/libs/cyassl/Makefile
parentf7ccdbec754cf1d626524db1e65e9a86243424de (diff)
downloadmaster-31e0f0ae-8e2106488a812dbb316776940a3b552a31b88549.tar.gz
master-31e0f0ae-8e2106488a812dbb316776940a3b552a31b88549.tar.bz2
master-31e0f0ae-8e2106488a812dbb316776940a3b552a31b88549.zip
Revert "[cyassl]: upgrade to 2.8.0"
Reverts the CyaSSL version bump for now since the update completely broke trunk building due to incompatible changes in the IO callback API which in turn breaks the core ustream-ssl package. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 38576
Diffstat (limited to 'package/libs/cyassl/Makefile')
-rw-r--r--package/libs/cyassl/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/package/libs/cyassl/Makefile b/package/libs/cyassl/Makefile
index df8335e800..063e572166 100644
--- a/package/libs/cyassl/Makefile
+++ b/package/libs/cyassl/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cyassl
-PKG_VERSION:=2.8.0
-PKG_RELEASE:=1
+PKG_VERSION:=1.6.5
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
PKG_SOURCE_URL:=http://www.yassl.com/
-PKG_MD5SUM:=7465d4815af90eff01095fa1b031ce09
+PKG_MD5SUM:=98c2c6350acf1d089756a1de9ccb9903
PKG_FIXUP:=patch-libtool
PKG_INSTALL:=1
@@ -38,15 +38,14 @@ TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
--without-zlib \
- --enable-singlethreaded \
- --disable-examples
+ --enable-singleThreaded
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.{so*,la} $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.{a,so*,la} $(1)/usr/lib/
endef
define Package/libcyassl/install