summaryrefslogtreecommitdiffstats
path: root/package/libs/cyassl/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-10-28 14:34:59 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-10-28 14:34:59 +0000
commit688ac024ac72804ab9ee170604763d9989f99b54 (patch)
tree7478daa28e62ca268e38ee9778b1154ed1f21683 /package/libs/cyassl/Makefile
parent14457da13f7a96daae8e3eec4da7fd45133f08ad (diff)
downloadmaster-31e0f0ae-688ac024ac72804ab9ee170604763d9989f99b54.tar.gz
master-31e0f0ae-688ac024ac72804ab9ee170604763d9989f99b54.tar.bz2
master-31e0f0ae-688ac024ac72804ab9ee170604763d9989f99b54.zip
upgrade to 2.8.0
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 38558
Diffstat (limited to 'package/libs/cyassl/Makefile')
-rw-r--r--package/libs/cyassl/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/package/libs/cyassl/Makefile b/package/libs/cyassl/Makefile
index 063e572166..df8335e800 100644
--- a/package/libs/cyassl/Makefile
+++ b/package/libs/cyassl/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cyassl
-PKG_VERSION:=1.6.5
-PKG_RELEASE:=2
+PKG_VERSION:=2.8.0
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
PKG_SOURCE_URL:=http://www.yassl.com/
-PKG_MD5SUM:=98c2c6350acf1d089756a1de9ccb9903
+PKG_MD5SUM:=7465d4815af90eff01095fa1b031ce09
PKG_FIXUP:=patch-libtool
PKG_INSTALL:=1
@@ -38,14 +38,15 @@ TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
--without-zlib \
- --enable-singleThreaded
+ --enable-singlethreaded \
+ --disable-examples
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.{a,so*,la} $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.{so*,la} $(1)/usr/lib/
endef
define Package/libcyassl/install