summaryrefslogtreecommitdiffstats
path: root/package/libs/argp-standalone/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-06-14 17:43:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-06-14 17:43:28 +0000
commit389144d7019a94654cc56e378742f82cd2c511e3 (patch)
tree478d997e9866459a60d626908ca8e6856997a9b4 /package/libs/argp-standalone/Makefile
parent988e3d85b06d581c057141c08e732883ec11cf17 (diff)
downloadmaster-31e0f0ae-389144d7019a94654cc56e378742f82cd2c511e3.tar.gz
master-31e0f0ae-389144d7019a94654cc56e378742f82cd2c511e3.tar.bz2
master-31e0f0ae-389144d7019a94654cc56e378742f82cd2c511e3.zip
argp-standalone: import package from packages.git
argp-standalone is required by elfutils, itself required by perf. So we'll move this package from packages.git and make it part of the core distribution. Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org> SVN-Revision: 45967
Diffstat (limited to 'package/libs/argp-standalone/Makefile')
-rw-r--r--package/libs/argp-standalone/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/package/libs/argp-standalone/Makefile b/package/libs/argp-standalone/Makefile
new file mode 100644
index 0000000000..8cf23fec5e
--- /dev/null
+++ b/package/libs/argp-standalone/Makefile
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2007-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=argp-standalone
+PKG_VERSION:=1.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.lysator.liu.se/~nisse/misc/
+PKG_MD5SUM:=720704bac078d067111b32444e24ba69
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
+
+PKG_LICENSE:=LGPL-2.1
+PKG_LICENSE:=Makefile.am
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/argp-standalone
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Hierarchial argument parsing broken out from glibc
+ URL:=http://www.lysator.liu.se/~nisse/misc/
+endef
+
+define Package/argp-standalone/description
+ GNU libc hierarchial argument parsing library broken out from glibc.
+endef
+
+MAKE_FLAGS += \
+ CFLAGS="$(TARGET_CFLAGS) $(FPIC)"
+
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_BUILD_DIR)/argp.h \
+ $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/libargp.a \
+ $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,argp-standalone))