summaryrefslogtreecommitdiffstats
path: root/package/libnl
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-06-26 20:44:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-06-26 20:44:28 +0000
commitff3d5025ac0c398277bf234e9608ab6490330b11 (patch)
tree4a76a02d5d7fea2447d3f79ffd4aec51e23add6e /package/libnl
parent0410a7b5493313a4d70a2a62b96c0dfe377e1fb6 (diff)
downloadmaster-31e0f0ae-ff3d5025ac0c398277bf234e9608ab6490330b11.tar.gz
master-31e0f0ae-ff3d5025ac0c398277bf234e9608ab6490330b11.tar.bz2
master-31e0f0ae-ff3d5025ac0c398277bf234e9608ab6490330b11.zip
remove obsolete kernel dependencies and version checks
SVN-Revision: 21956
Diffstat (limited to 'package/libnl')
-rw-r--r--package/libnl/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/package/libnl/Makefile b/package/libnl/Makefile
index 6802ed16f8..eb9831a21e 100644
--- a/package/libnl/Makefile
+++ b/package/libnl/Makefile
@@ -37,18 +37,16 @@ define Build/Compile
install
endef
-ifneq ($(CONFIG_LINUX_2_6),)
- define Build/InstallDev
+define Build/InstallDev
$(INSTALL_DIR) $(1)
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
mkdir -p $(1)/usr/include/libnl
$(CP) $(PKG_BUILD_DIR)/include/linux $(1)/usr/include/libnl/
- endef
+endef
- define Package/libnl/install
+define Package/libnl/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libnl.so.* $(1)/usr/lib/
- endef
-endif
+endef
$(eval $(call BuildPackage,libnl))