summaryrefslogtreecommitdiffstats
path: root/package/libnl-tiny/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-30 13:57:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-30 13:57:29 +0000
commit938553bd69d1484b9d25495da4e7c2f09927638c (patch)
treecaace55defd2b5d38382a27ea1ae384c1f8ecc80 /package/libnl-tiny/Makefile
parent4e12c9d210531b67d6428cb15e763f49decd8199 (diff)
downloadmaster-31e0f0ae-938553bd69d1484b9d25495da4e7c2f09927638c.tar.gz
master-31e0f0ae-938553bd69d1484b9d25495da4e7c2f09927638c.tar.bz2
master-31e0f0ae-938553bd69d1484b9d25495da4e7c2f09927638c.zip
add libnl-tiny as a small replacement for libnl with only genl support included
SVN-Revision: 15507
Diffstat (limited to 'package/libnl-tiny/Makefile')
-rw-r--r--package/libnl-tiny/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/package/libnl-tiny/Makefile b/package/libnl-tiny/Makefile
new file mode 100644
index 0000000000..46a72593d1
--- /dev/null
+++ b/package/libnl-tiny/Makefile
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libnl-tiny
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libnl-tiny
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=netlink socket library
+endef
+
+define Package/libnl-tiny/description
+ This package contains a stripped down version of libnl
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ all
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/lib $(1)/usr/include/libnl-tiny
+ $(CP) $(PKG_BUILD_DIR)/include/* $(1)/usr/include/libnl-tiny
+ $(CP) $(PKG_BUILD_DIR)/libnl-tiny.so $(1)/usr/lib/
+endef
+
+define Package/libnl-tiny/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/libnl-tiny.so $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libnl-tiny))