summaryrefslogtreecommitdiffstats
path: root/package/kexec-tools
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-07-07 03:00:04 +0000
committerNicolas Thill <nico@openwrt.org>2009-07-07 03:00:04 +0000
commit69d65604a24bc0d48ebb231ae6f48a4deb9adfc8 (patch)
treea6035ffcd0a343bbfcf567c99d6894725e19f5d0 /package/kexec-tools
parent4702698c68be9023f5a7f4909c38f0d5ef5ef993 (diff)
downloadmaster-31e0f0ae-69d65604a24bc0d48ebb231ae6f48a4deb9adfc8.tar.gz
master-31e0f0ae-69d65604a24bc0d48ebb231ae6f48a4deb9adfc8.tar.bz2
master-31e0f0ae-69d65604a24bc0d48ebb231ae6f48a4deb9adfc8.zip
fix kexec-tools builds when libc != uClibc, strip quotes from KEXEC_TARGET_NAME config option
SVN-Revision: 16729
Diffstat (limited to 'package/kexec-tools')
-rw-r--r--package/kexec-tools/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/kexec-tools/Makefile b/package/kexec-tools/Makefile
index 910b6a25ae..3f6137d3da 100644
--- a/package/kexec-tools/Makefile
+++ b/package/kexec-tools/Makefile
@@ -35,9 +35,11 @@ define Package/kexec-tools/config
source "$(SOURCE)/kexec-config.in"
endef
+KEXEC_TARGET_NAME:=$(call qstrip,$(CONFIG_KEXEC_TOOLS_TARGET_NAME))-linux-$(TARGET_SUFFIX)
+
CONFIGURE_ARGS = \
- --target=$(CONFIG_KEXEC_TOOLS_TARGET_NAME)-linux-$(TARGET_SUFFIX) \
- --host=$(GNU_TARGET_NAME)-uclibc \
+ --target=$(KEXEC_TARGET_NAME) \
+ --host=$(REAL_GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--program-prefix="" \
--program-suffix="" \