summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorMatteo Croce <matteo.croce@canonical.com>2016-08-11 16:11:39 +0200
committerJohn Crispin <john@phrozen.org>2016-08-15 15:32:38 +0200
commit2ebb4733e176560084809fb83d45366d929e1fc8 (patch)
treeedf02be0812f914425cf4bcbe68fe0cb11619c68 /package/kernel
parent9f5ee6f6c03887d34f56d54daa77866e34b8833e (diff)
downloadmaster-31e0f0ae-2ebb4733e176560084809fb83d45366d929e1fc8.tar.gz
master-31e0f0ae-2ebb4733e176560084809fb83d45366d929e1fc8.tar.bz2
master-31e0f0ae-2ebb4733e176560084809fb83d45366d929e1fc8.zip
kernel: add kmod-squashfs
add kernel package to build squashfs as module when it's not the root filesystem Signed-off-by: Matteo Croce <matteo.croce@canonical.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/fs.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 844a3c96ab..c42260a96f 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -420,6 +420,22 @@ endef
$(eval $(call KernelPackage,fs-reiserfs))
+define KernelPackage/fs-squashfs
+ SUBMENU:=$(FS_MENU)
+ TITLE:=SquashFS 4.0 filesystem support
+ KCONFIG:=CONFIG_SQUASHFS \
+ CONFIG_SQUASHFS_XZ=y
+ FILES:=$(LINUX_DIR)/fs/squashfs/squashfs.ko
+ AUTOLOAD:=$(call AutoLoad,30,squashfs,1)
+endef
+
+define KernelPackage/fs-squashfs/description
+ Kernel module for SquashFS 4.0 support
+endef
+
+$(eval $(call KernelPackage,fs-squashfs))
+
+
define KernelPackage/fs-udf
SUBMENU:=$(FS_MENU)
TITLE:=UDF filesystem support