summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-09-15 03:48:20 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-09-15 03:48:20 +0000
commitfe247d02bd0e7670842ad76eec60272fba1c8e6c (patch)
tree178cb20ac1fa623043690f21c2d92d67ccfc6a1a /package/kernel
parent7fb38706717f34fd2ccc41f2860cff43d3c91898 (diff)
downloadmaster-31e0f0ae-fe247d02bd0e7670842ad76eec60272fba1c8e6c.tar.gz
master-31e0f0ae-fe247d02bd0e7670842ad76eec60272fba1c8e6c.tar.bz2
master-31e0f0ae-fe247d02bd0e7670842ad76eec60272fba1c8e6c.zip
Support for RTL-8139C+ ethernet adapters Signed-off-by: Nathan Williams <nathan@traverse.com.au>
SVN-Revision: 23068
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/netdevices.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/netdevices.mk b/package/kernel/modules/netdevices.mk
index c3f8d1ff38..69ec517adb 100644
--- a/package/kernel/modules/netdevices.mk
+++ b/package/kernel/modules/netdevices.mk
@@ -205,6 +205,22 @@ endef
$(eval $(call KernelPackage,8139too))
+define KernelPackage/8139cp
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=RealTek RTL-8139C+ PCI Fast Ethernet Adapter kernel support
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_8139CP
+ FILES:=$(LINUX_DIR)/drivers/net/8139cp.ko
+ AUTOLOAD:=$(call AutoLoad,50,8139cp)
+endef
+
+define KernelPackage/8139cp/description
+ Kernel module for RealTek RTL-8139C+ PCI Fast Ethernet adapters.
+endef
+
+$(eval $(call KernelPackage,8139cp))
+
+
define KernelPackage/r8169
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=RealTek RTL-8169 PCI Gigabit Ethernet Adapter kernel support