summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-07-18 20:40:15 +0000
committerJonas Gorski <jogo@openwrt.org>2013-07-18 20:40:15 +0000
commitfe1a84ad7133afed1b0c28c728817571436f5b6b (patch)
treecbab4e4930b1d609119eee38a74b500d0f21a424 /package/kernel
parent5e239a0fa47a84cbb11b4a52f5527110f105d414 (diff)
downloadmaster-31e0f0ae-fe1a84ad7133afed1b0c28c728817571436f5b6b.tar.gz
master-31e0f0ae-fe1a84ad7133afed1b0c28c728817571436f5b6b.tar.bz2
master-31e0f0ae-fe1a84ad7133afed1b0c28c728817571436f5b6b.zip
kernel: kmod-gpio-mcp23s08 depends on i2c-core
But only if it is selected, so make it a conditionl dependency. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 37420
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/other.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 9e97bb566f..f850581ba7 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -135,7 +135,7 @@ $(eval $(call KernelPackage,gpio-dev))
define KernelPackage/gpio-mcp23s08
SUBMENU:=$(OTHER_MENU)
TITLE:=Microchip MCP23xxx I/O expander
- DEPENDS:=@GPIO_SUPPORT
+ DEPENDS:=@GPIO_SUPPORT +PACKAGE_kmod-i2c-core:kmod-i2c-core
KCONFIG:=CONFIG_GPIO_MCP23S08
FILES:=$(LINUX_DIR)/drivers/gpio/gpio-mcp23s08.ko
AUTOLOAD:=$(call AutoLoad,40,gpio-mcp23s08)