summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-02-16 04:30:48 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-02-16 04:30:48 +0000
commitfdd629c8519134583dcf95c3859faa7ee11ef309 (patch)
tree41c1da7f1a6d150b3f4f9cbbf36f920ae9f1a8b8 /package/kernel
parentc2e122528467a2f2018a84c3e0333b7211717d9f (diff)
downloadmaster-31e0f0ae-fdd629c8519134583dcf95c3859faa7ee11ef309.tar.gz
master-31e0f0ae-fdd629c8519134583dcf95c3859faa7ee11ef309.tar.bz2
master-31e0f0ae-fdd629c8519134583dcf95c3859faa7ee11ef309.zip
add kmod for 2.6.26+ in-kernel uvc video driver (#4637, thanks moh_de)
SVN-Revision: 14526
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/video.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/modules/video.mk b/package/kernel/modules/video.mk
index af0a570615..086bbde91f 100644
--- a/package/kernel/modules/video.mk
+++ b/package/kernel/modules/video.mk
@@ -131,3 +131,20 @@ endef
$(eval $(call KernelPackage,video-pwc))
+define KernelPackage/video-uvc
+ SUBMENU:=$(VIDEO_MENU)
+ TITLE:=USB Video Class (UVC) support
+ DEPENDS:=@LINUX_2_6 @!LINUX_2_6_25 @!LINUX_2_6_24 @!LINUX_2_6_23 @USB_SUPPORT +kmod-usb-core +kmod-video-core
+ KCONFIG:= \
+ CONFIG_USB_VIDEO_CLASS \
+ CONFIG_USB_VIDEO_CLASS_INPUT_EVDEV=y
+ FILES:=$(LINUX_DIR)/drivers/media/video/uvc/uvcvideo.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,90,uvcvideo)
+endef
+
+
+define KernelPackage/video-uvc/description
+ Kernel modules for supporting USB Video Class (UVC) devices.
+endef
+
+$(eval $(call KernelPackage,video-uvc))