summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-10-29 15:02:38 +0000
committerJohn Crispin <john@openwrt.org>2014-10-29 15:02:38 +0000
commitfd5873eb33d931b41fa39c50a11512dcd4402f60 (patch)
tree5f55fa04858913710b3e674f5e176e505334757d /package/kernel
parentd0bf15f235951973836da586c05693c0563ed4f2 (diff)
downloadmaster-31e0f0ae-fd5873eb33d931b41fa39c50a11512dcd4402f60.tar.gz
master-31e0f0ae-fd5873eb33d931b41fa39c50a11512dcd4402f60.tar.bz2
master-31e0f0ae-fd5873eb33d931b41fa39c50a11512dcd4402f60.zip
Add support for DHT11 driver
The DHT11 is a temperature and humidity sensor supported by linux since 3.14. This patch is tested on recent mxs with kernel 3.14.18. Signed-off-by: Harald Geyer <harald@ccbib.org> SVN-Revision: 43103
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/other.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 58aae3ce58..c514fd7366 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -258,6 +258,26 @@ endef
$(eval $(call KernelPackage,iio-ad799x))
+
+define KernelPackage/iio-dht11
+ SUBMENU:=$(OTHER_MENU)
+ DEPENDS:=kmod-iio-core @GPIO_SUPPORT @USES_DEVICETREE
+ TITLE:=DHT11 (and compatible) humidity and temperature sensors
+ KCONFIG:= \
+ CONFIG_DHT11
+ FILES:=$(LINUX_DIR)/drivers/iio/humidity/dht11.ko
+ AUTOLOAD:=$(call AutoLoad,56,dht11)
+endef
+
+define KernelPackage/iio-dht11/description
+ support for DHT11 and DHT22 digitial humidity and temperature sensors
+ attached at GPIO lines. You will need a custom device tree file to
+ specify the GPIO line to use.
+endef
+
+$(eval $(call KernelPackage,iio-dht11))
+
+
define KernelPackage/lp
SUBMENU:=$(OTHER_MENU)
TITLE:=Parallel port and line printer support