summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-03-19 23:48:38 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-03-19 23:48:38 +0000
commitf6ad186eec0faaf55b7a00558d33f08bca28313b (patch)
tree9dee8758f676e7519d6d27cc4fa1135d86c2b055 /package/kernel
parent3454c35127118f26479c4b5972800c63b4e8515f (diff)
downloadmaster-31e0f0ae-f6ad186eec0faaf55b7a00558d33f08bca28313b.tar.gz
master-31e0f0ae-f6ad186eec0faaf55b7a00558d33f08bca28313b.tar.bz2
master-31e0f0ae-f6ad186eec0faaf55b7a00558d33f08bca28313b.zip
kernel: add kmod-acpi-button
SVN-Revision: 31037
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk17
1 files changed, 16 insertions, 1 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index b57d055d36..69c7a78fcb 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -890,3 +890,18 @@ endef
$(eval $(call KernelPackage,serial-8250))
+
+define KernelPackage/acpi-button
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=ACPI Button Support
+ DEPENDS:=@(TARGET_x86_generic||TARGET_x86_kvm_guest||TARGET_x86_xen_domu) +kmod-input-evdev
+ KCONFIG:=CONFIG_ACPI_BUTTON
+ FILES:=$(LINUX_DIR)/drivers/acpi/button.ko
+ AUTOLOAD:=$(call AutoLoad,06,button)
+endef
+
+define KernelPackage/acpi-button/description
+ Kernel module for ACPI Button support
+endef
+
+$(eval $(call KernelPackage,acpi-button))