summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-03 19:35:42 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-03 19:35:43 +0200
commitf5088dc13f5aaaf3eade8cc78f3904eafdca9440 (patch)
treefbdb497fd672bcab61f711cb3f72150daeb21b6c /package/kernel
parentd5ee23ee275fcd6550b0051de59706cc928cdac8 (diff)
downloadmaster-31e0f0ae-f5088dc13f5aaaf3eade8cc78f3904eafdca9440.tar.gz
master-31e0f0ae-f5088dc13f5aaaf3eade8cc78f3904eafdca9440.tar.bz2
master-31e0f0ae-f5088dc13f5aaaf3eade8cc78f3904eafdca9440.zip
kernel: fix duplicate drivers for the PC speaker in one package
Only use the ALSA capable one, it supports regular beeps as well Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/sound.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index d09cf21aba..52a44d6a8a 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -259,12 +259,10 @@ define KernelPackage/pcspkr
DEPENDS:=@TARGET_x86 +kmod-input-core
TITLE:=PC speaker support
KCONFIG:= \
- CONFIG_INPUT_PCSPKR \
CONFIG_SND_PCSP
FILES:= \
- $(LINUX_DIR)/drivers/input/misc/pcspkr.ko \
$(LINUX_DIR)/sound/drivers/pcsp/snd-pcsp.ko
- AUTOLOAD:=$(call AutoLoad,50,pcspkr snd-pcsp)
+ AUTOLOAD:=$(call AutoLoad,50,snd-pcsp)
$(call AddDepends/sound)
endef