summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2012-07-11 23:38:16 +0000
committerLuka Perkov <luka@openwrt.org>2012-07-11 23:38:16 +0000
commitf3112b06d2421cf9fed21605bd0950ec7d379f3a (patch)
tree34d702cdbafe1172ef514a8a5aec101bca6f8509 /package/kernel
parent283021ac15faec84a1764d7883cfb47db7847d0c (diff)
downloadmaster-31e0f0ae-f3112b06d2421cf9fed21605bd0950ec7d379f3a.tar.gz
master-31e0f0ae-f3112b06d2421cf9fed21605bd0950ec7d379f3a.tar.bz2
master-31e0f0ae-f3112b06d2421cf9fed21605bd0950ec7d379f3a.zip
openssl: enable the use of cryptodev digests
SVN-Revision: 32673
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/crypto.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index eb256be740..f9ce8f96da 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -393,7 +393,7 @@ $(eval $(call KernelPackage,crypto-misc))
define KernelPackage/crypto-ocf
TITLE:=OCF modules
- DEPENDS:=+@OPENSSL_ENGINE @!TARGET_uml +kmod-crypto-manager
+ DEPENDS:=+@OPENSSL_ENGINE_CRYPTO @!TARGET_uml +kmod-crypto-manager
KCONFIG:= \
CONFIG_OCF_OCF \
CONFIG_OCF_CRYPTODEV \
@@ -417,7 +417,7 @@ $(eval $(call KernelPackage,crypto-ocf))
define KernelPackage/crypto-ocf-hifn7751
TITLE:=OCF support for Hifn 6500/7751/7811/795x, Invertex AEON and NetSec 7751 devices
- DEPENDS:=+@OPENSSL_ENGINE @PCI_SUPPORT @!TARGET_uml kmod-crypto-ocf
+ DEPENDS:=+@OPENSSL_ENGINE_CRYPTO @PCI_SUPPORT @!TARGET_uml kmod-crypto-ocf
KCONFIG:=CONFIG_OCF_HIFN
FILES:=$(LINUX_DIR)/crypto/ocf/hifn/hifn7751.ko
AUTOLOAD:=$(call AutoLoad,10,hifn7751)
@@ -429,7 +429,7 @@ $(eval $(call KernelPackage,crypto-ocf-hifn7751))
define KernelPackage/crypto-ocf-hifnhipp
TITLE:=OCF support for Hifn 7855/8155 devices
- DEPENDS:=+@OPENSSL_ENGINE @PCI_SUPPORT @!TARGET_uml kmod-crypto-ocf
+ DEPENDS:=+@OPENSSL_ENGINE_CRYPTO @PCI_SUPPORT @!TARGET_uml kmod-crypto-ocf
KCONFIG:=CONFIG_OCF_HIFNHIPP
FILES:=$(LINUX_DIR)/crypto/ocf/hifn/hifnHIPP.ko
AUTOLOAD:=$(call AutoLoad,10,hifnHIPP)