summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2008-11-28 18:04:36 +0000
committerJo-Philipp Wich <jow@openwrt.org>2008-11-28 18:04:36 +0000
commite9cf2c505a7b6887076756f406cadd988cb656c1 (patch)
tree6ada59a14bf474435874ba73bb3fdd2c51cecb6a /package/kernel
parentb2ec8ffd5c8e4bc79ac1e3e9f314a96bb8ce17c1 (diff)
downloadmaster-31e0f0ae-e9cf2c505a7b6887076756f406cadd988cb656c1.tar.gz
master-31e0f0ae-e9cf2c505a7b6887076756f406cadd988cb656c1.tar.bz2
master-31e0f0ae-e9cf2c505a7b6887076756f406cadd988cb656c1.zip
split Soekris profile into 45xx and 48xx, add kernel package for required watchdog driver on 45xx
SVN-Revision: 13411
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 79b01c16c7..838526939f 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -541,6 +541,22 @@ endef
$(eval $(call KernelPackage,scx200-wdt))
+define KernelPackage/sc520-wdt
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Natsemi SC520 Watchdog support
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_SC520_WDT
+ FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/sc520_wdt.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,50,sc520_wdt)
+endef
+
+define KernelPackage/sc520-wdt/description
+ Kernel module for SC520 Watchdog
+endef
+
+$(eval $(call KernelPackage,sc520-wdt))
+
+
define KernelPackage/input-core
SUBMENU:=$(OTHER_MENU)
TITLE:=Input device core