summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-02-24 01:11:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-02-24 01:11:16 +0000
commitcf3b7563cfc1c293c633bb361f7660ff67c0dc6c (patch)
treef15fabd79fedf796821956b6362d791b36eb8af3 /package/kernel
parentac905e8a7b3c75fd5651ab9a7a54c5f945b3750f (diff)
downloadmaster-31e0f0ae-cf3b7563cfc1c293c633bb361f7660ff67c0dc6c.tar.gz
master-31e0f0ae-cf3b7563cfc1c293c633bb361f7660ff67c0dc6c.tar.bz2
master-31e0f0ae-cf3b7563cfc1c293c633bb361f7660ff67c0dc6c.zip
add kmod-oprofile to package/kernel
SVN-Revision: 25690
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 60a534c86d..0ecc7b3786 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -663,6 +663,21 @@ endef
$(eval $(call KernelPackage,mmc-atmelmci,1))
+define KernelPackage/oprofile
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=OProfile profiling support
+ KCONFIG:=CONFIG_OPROFILE
+ FILES:=$(LINUX_DIR)/arch/$(LINUX_KARCH)/oprofile/oprofile.$(LINUX_KMOD_SUFFIX)
+ DEPENDS:=@KERNEL_PROFILING
+endef
+
+define KernelPackage/oprofile/description
+ Kernel module for support for oprofile system profiling.
+endef
+
+$(eval $(call KernelPackage,oprofile))
+
+
define KernelPackage/rfkill
SUBMENU:=$(OTHER_MENU)
TITLE:=RF switch subsystem support