summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2013-01-06 16:21:29 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2013-01-06 16:21:29 +0000
commitbef592844bd2cb1c3561f16ce62c31eecd5cc5d5 (patch)
tree893e9a38b7644c92630616f3665a9907122d612a /package/kernel
parent5154270694c406891585b7c35f2c3293bc86e601 (diff)
downloadmaster-31e0f0ae-bef592844bd2cb1c3561f16ce62c31eecd5cc5d5.tar.gz
master-31e0f0ae-bef592844bd2cb1c3561f16ce62c31eecd5cc5d5.tar.bz2
master-31e0f0ae-bef592844bd2cb1c3561f16ce62c31eecd5cc5d5.zip
zram: add package to use compressed ram disk for swap
The busybox size is increased by 3.2KByte uncompressed on bcm47xx with this commit. This zram-swap automatically creates a zram device, a swap partition on it and make the kernel swap pages to it. Thank you Bastian Bittorf <bittorf@bluebottle.com> for idea and the script. SVN-Revision: 35025
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index ddaef8d901..5d3e00a87f 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -747,3 +747,24 @@ define KernelPackage/ikconfig/description
endef
$(eval $(call KernelPackage,ikconfig))
+
+
+define KernelPackage/zram
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=ZRAM
+ DEPENDS:=@!LINUX_3_3 +kmod-lib-lzo
+ KCONFIG:= \
+ CONFIG_ZSMALLOC \
+ CONFIG_ZRAM \
+ CONFIG_ZRAM_DEBUG=n
+ FILES:= \
+ $(LINUX_DIR)/drivers/staging/zsmalloc/zsmalloc.ko \
+ $(LINUX_DIR)/drivers/staging/zram/zram.ko
+ AUTOLOAD:=$(call AutoLoad,20,zsmalloc zram)
+endef
+
+define KernelPackage/zram/description
+ Compressed RAM block device support
+endef
+
+$(eval $(call KernelPackage,zram))