summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-25 15:49:54 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-25 15:49:54 +0000
commitbca45d6d8afe8eb82d36c2b50940a2e0c8cc33e9 (patch)
tree35115202f4049fbe311a344909adad051ab8780b /package/kernel
parent29ccabae44e01c288b1d2aaf1bb0236846e0da89 (diff)
downloadmaster-31e0f0ae-bca45d6d8afe8eb82d36c2b50940a2e0c8cc33e9.tar.gz
master-31e0f0ae-bca45d6d8afe8eb82d36c2b50940a2e0c8cc33e9.tar.bz2
master-31e0f0ae-bca45d6d8afe8eb82d36c2b50940a2e0c8cc33e9.zip
move i2c modules back to target modules.mk
SVN-Revision: 32850
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/i2c.mk35
1 files changed, 0 insertions, 35 deletions
diff --git a/package/kernel/modules/i2c.mk b/package/kernel/modules/i2c.mk
index 50501cf4ba..0eb8a07a81 100644
--- a/package/kernel/modules/i2c.mk
+++ b/package/kernel/modules/i2c.mk
@@ -101,41 +101,6 @@ endef
$(eval $(call KernelPackage,i2c-gpio))
-I2C_SCX200_MODULES:=\
- CONFIG_SCx200_I2C:drivers/i2c/busses/scx200_i2c
-
-define KernelPackage/i2c-scx200
- $(call i2c_defaults,$(I2C_SCX200_MODULES),59)
- TITLE:=Geode SCx200 I2C using GPIO pins
- DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-algo-bit
- KCONFIG+= \
- CONFIG_SCx200_I2C_SCL=12 \
- CONFIG_SCx200_I2C_SDA=13
-endef
-
-define KernelPackage/i2c-scx200/description
- Kernel module for I2C using GPIO pins on the Geode SCx200 processors.
-endef
-
-$(eval $(call KernelPackage,i2c-scx200))
-
-
-I2C_SCX200_ACB_MODULES:=\
- CONFIG_SCx200_ACB:drivers/i2c/busses/scx200_acb
-
-define KernelPackage/i2c-scx200-acb
- $(call i2c_defaults,$(I2C_SCX200_ACB_MODULES),59)
- TITLE:=Geode SCx200 ACCESS.bus support
- DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-algo-bit
-endef
-
-define KernelPackage/i2c-scx200-acb/description
- Kernel module for I2C using the ACCESS.bus controllers on the Geode SCx200
- and SC1100 processors and the CS5535 and CS5536 Geode companion devices.
-endef
-
-$(eval $(call KernelPackage,i2c-scx200-acb))
-
OF_I2C_MODULES:=\
CONFIG_OF_I2C:drivers/of/of_i2c