summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2008-07-29 23:49:16 +0000
committerJohn Crispin <john@openwrt.org>2008-07-29 23:49:16 +0000
commita817bad21ff3331050843bd25b93d2e6cbcea898 (patch)
treead24864779b789699a5a8b907dc025e5b4a03a43 /package/kernel
parentb639fc4b005b3c83458e1f66d3fc84530828319a (diff)
downloadmaster-31e0f0ae-a817bad21ff3331050843bd25b93d2e6cbcea898.tar.gz
master-31e0f0ae-a817bad21ff3331050843bd25b93d2e6cbcea898.tar.bz2
master-31e0f0ae-a817bad21ff3331050843bd25b93d2e6cbcea898.zip
add lm sensor and clean up dependency, fixes #3821
SVN-Revision: 11999
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/hwmon.mk16
1 files changed, 15 insertions, 1 deletions
diff --git a/package/kernel/modules/hwmon.mk b/package/kernel/modules/hwmon.mk
index 8ecf6cc8a9..943b4a7e82 100644
--- a/package/kernel/modules/hwmon.mk
+++ b/package/kernel/modules/hwmon.mk
@@ -30,7 +30,7 @@ $(eval $(call KernelPackage,hwmon-core))
define KernelPackage/hwmon-lm77
SUBMENU:=$(HWMON_MENU)
TITLE:=LM77 monitoring support
- DEPENDS:=kmod-hwmon-core kmod-i2c-core
+ DEPENDS:=kmod-hwmon-core +kmod-i2c-core
KCONFIG:=CONFIG_SENSORS_LM77
FILES:=$(LINUX_DIR)/drivers/hwmon/lm77.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,60,lm77)
@@ -42,6 +42,20 @@ endef
$(eval $(call KernelPackage,hwmon-lm77))
+define KernelPackage/hwmon-lm90
+ SUBMENU:=$(HWMON_MENU)
+ TITLE:=LM90 monitoring support
+ DEPENDS:=kmod-hwmon-core +kmod-i2c-core
+ KCONFIG:=CONFIG_SENSORS_LM90
+ FILES:=$(LINUX_DIR)/drivers/hwmon/lm90.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,60,lm90)
+endef
+
+define KernelPackage/hwmon-lm90/description
+ Kernel module for LM90 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm90))
define KernelPackage/hwmon-pc87360
SUBMENU:=$(HWMON_MENU)