summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-04-29 15:08:21 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-04-29 15:08:21 +0000
commit8c60f7825b02d195c59502dc617f6e0fd9220b74 (patch)
tree9df0403719afc1f1c2fd55ecd998d32fcf90d494 /package/kernel
parentf6d5998d31a0962f49c62868c2e258b74b9da50d (diff)
downloadmaster-31e0f0ae-8c60f7825b02d195c59502dc617f6e0fd9220b74.tar.gz
master-31e0f0ae-8c60f7825b02d195c59502dc617f6e0fd9220b74.tar.bz2
master-31e0f0ae-8c60f7825b02d195c59502dc617f6e0fd9220b74.zip
package/kernel: add i2c module support for Freescale MPC processors
Signed-off-by: Wojciech Dubowik <Wojciech.Dubowik@neratec.com> SVN-Revision: 31524
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/i2c.mk18
1 files changed, 17 insertions, 1 deletions
diff --git a/package/kernel/modules/i2c.mk b/package/kernel/modules/i2c.mk
index 0d525cc6d3..d2b45d63d2 100644
--- a/package/kernel/modules/i2c.mk
+++ b/package/kernel/modules/i2c.mk
@@ -143,7 +143,8 @@ OF_I2C_MODULES:=\
define KernelPackage/of-i2c
$(call i2c_defaults,$(OF_I2C_MODULES),58)
TITLE:=OpenFirmware I2C accessors
- DEPENDS:=@TARGET_ppc40x||TARGET_ppc4xx kmod-i2c-core
+ DEPENDS:=@TARGET_ppc40x||TARGET_ppc4xx||TARGET_mpc52xx||TARGET_mpc83xx||TARGET_mpc85xx \
+ kmod-i2c-core
endef
define KernelPackage/of-i2c/description
@@ -152,6 +153,21 @@ endef
$(eval $(call KernelPackage,of-i2c))
+I2C_MPC_MODULES:=\
+ CONFIG_I2C_MPC:drivers/i2c/busses/i2c-mpc
+
+define KernelPackage/i2c-mpc
+ $(call i2c_defaults,$(I2C_MPC_MODULES),59)
+ TITLE:=MPC I2C accessors
+ DEPENDS:=@TARGET_mpc52xx||TARGET_mpc83xx||TARGET_mpc85xx \
+ +kmod-i2c-core +kmod-of-i2c
+endef
+
+define KernelPackage/i2c-mpc/description
+ Kernel module for Freescale MPC52xx MPC83xx MPC85xx I2C accessors.
+endef
+
+$(eval $(call KernelPackage,i2c-mpc))
I2C_IBM_IIC_MODULES:=\
CONFIG_I2C_IBM_IIC:drivers/i2c/busses/i2c-ibm_iic