summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2016-07-31 15:42:53 +0300
committerJohn Crispin <john@phrozen.org>2016-08-03 15:30:13 +0200
commit6e68a5dd11bc68981377042f49c0e0d3c978a84d (patch)
treea15d071df26926e83b2a013ade6fb232c39197b3 /package/kernel
parent828e25e32569704cbfe9e98c9fa7c533ffbbcb65 (diff)
downloadmaster-31e0f0ae-6e68a5dd11bc68981377042f49c0e0d3c978a84d.tar.gz
master-31e0f0ae-6e68a5dd11bc68981377042f49c0e0d3c978a84d.tar.bz2
master-31e0f0ae-6e68a5dd11bc68981377042f49c0e0d3c978a84d.zip
linux/modules: Add SCH5627 Super I/O chips
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/hwmon.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index f7a92eda1e..0a8115c28b 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -252,6 +252,22 @@ endef
$(eval $(call KernelPackage,hwmon-sht21))
+define KernelPackage/hwmon-sch5627
+ TITLE:=SMSC SCH5627 monitoring support
+ KCONFIG:=CONFIG_SENSORS_SCH5627
+ FILES:= \
+ $(LINUX_DIR)/drivers/hwmon/sch5627.ko \
+ $(LINUX_DIR)/drivers/hwmon/sch56xx-common.ko
+ AUTOLOAD:=$(call AutoProbe,sch5627)
+ $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-sch5627/description
+ SMSC SCH5627 Super I/O chips include complete hardware monitoring
+endef
+
+$(eval $(call KernelPackage,hwmon-sch5627))
+
define KernelPackage/hwmon-pc87360
TITLE:=PC87360 monitoring support
KCONFIG:=CONFIG_SENSORS_PC87360