summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-12-01 22:48:52 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-12-01 22:48:52 +0000
commit6a0b84e6719221f78d32b35ada6a9385a16dc4b3 (patch)
tree7acc9ded456b6a7b70da8450e2044edae2067124 /package/kernel
parent80221fcd2a66e6a1a4ebd79d98ae881a549fc521 (diff)
downloadmaster-31e0f0ae-6a0b84e6719221f78d32b35ada6a9385a16dc4b3.tar.gz
master-31e0f0ae-6a0b84e6719221f78d32b35ada6a9385a16dc4b3.tar.bz2
master-31e0f0ae-6a0b84e6719221f78d32b35ada6a9385a16dc4b3.zip
package/kernel: create packages for the rtl8366* drivers
This allows to enable rtl8366 switches family support, which are optional (present on few boards). Based on a patch by Roman Yeryomin <roman@advem.lv> SVN-Revision: 29388
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/netdevices.mk45
1 files changed, 45 insertions, 0 deletions
diff --git a/package/kernel/modules/netdevices.mk b/package/kernel/modules/netdevices.mk
index 511ca7be41..71157cdccb 100644
--- a/package/kernel/modules/netdevices.mk
+++ b/package/kernel/modules/netdevices.mk
@@ -157,6 +157,51 @@ endef
$(eval $(call KernelPackage,switch-ip17xx))
+define KernelPackage/switch-rtl8366_smi
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Realtek RTL8366 SMI switch interface support
+ DEPENDS:=@GPIO_SUPPORT +kmod-swconfig
+ KCONFIG:=CONFIG_RTL8366_SMI
+ FILES:=$(LINUX_DIR)/drivers/net/phy/rtl8366_smi.ko
+ AUTOLOAD:=$(call AutoLoad,42,rtl8366_smi)
+endef
+
+define KernelPackage/switch-rtl8366_smi/description
+ Realtek RTL8366 series SMI switch interface support
+endef
+
+$(eval $(call KernelPackage,switch-rtl8366_smi))
+
+define KernelPackage/switch-rtl8366rb
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Realtek RTL8366RB switch support
+ DEPENDS:=+kmod-switch-rtl8366_smi
+ KCONFIG:=CONFIG_RTL8366RB_PHY
+ FILES:=$(LINUX_DIR)/drivers/net/phy/rtl8366rb.ko
+ AUTOLOAD:=$(call AutoLoad,43,rtl8366rb)
+endef
+
+define KernelPackage/switch-rtl8366rb/description
+ Realtek RTL8366RB switch support
+endef
+
+$(eval $(call KernelPackage,switch-rtl8366rb))
+
+define KernelPackage/switch-rtl8366s
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Realtek RTL8366S switch support
+ DEPENDS:=+kmod-switch-rtl8366_smi
+ KCONFIG:=CONFIG_RTL8366S_PHY
+ FILES:=$(LINUX_DIR)/drivers/net/phy/rtl8366s.ko
+ AUTOLOAD:=$(call AutoLoad,43,rtl8366s)
+endef
+
+define KernelPackage/switch-rtl8366s/description
+ Realtek RTL8366S switch support
+endef
+
+$(eval $(call KernelPackage,switch-rtl8366s))
+
define KernelPackage/natsemi
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=National Semiconductor DP8381x series