summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-05-31 16:57:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-05-31 16:57:01 +0000
commit68af223efe382bf2f58b4196479a978b5fb3bcb0 (patch)
treeef17990a3df3a170c21dcc48c2577b1a9f1d1472 /package/kernel
parentba5b3ece5da02f16c64c7010bf543072c9a766c1 (diff)
downloadmaster-31e0f0ae-68af223efe382bf2f58b4196479a978b5fb3bcb0.tar.gz
master-31e0f0ae-68af223efe382bf2f58b4196479a978b5fb3bcb0.tar.bz2
master-31e0f0ae-68af223efe382bf2f58b4196479a978b5fb3bcb0.zip
x86: remove pata-amd driver from generic x86 images, add addition cs553x modules
The pata-cs5535/pata-cs5536 driver is actually fairly rare: it only gets used on embedded platforms. Therefore, we remove it from the generic x86 configuration. Also, add definitions for other useful geode modules (high-res timers, MFGPT timers, etc). Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com> SVN-Revision: 27037
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/block.mk64
-rw-r--r--package/kernel/modules/other.mk34
2 files changed, 97 insertions, 1 deletions
diff --git a/package/kernel/modules/block.mk b/package/kernel/modules/block.mk
index 28935804f3..218d048de5 100644
--- a/package/kernel/modules/block.mk
+++ b/package/kernel/modules/block.mk
@@ -471,6 +471,70 @@ endef
$(eval $(call KernelPackage,ide-it821x))
+define KernelPackage/cs5535
+ TITLE:=NSC/AMD CS5535 chipset support
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_BLK_DEV_CS5535
+ FILES=$(LINUX_DIR)/drivers/ide/cs5535.ko
+ AUTOLOAD:=$(call AutoLoad,30,cs5535,1)
+ $(call AddDepends/ide)
+endef
+
+define KernelPackage/cs5535/description
+ Kernel module for the NSC/AMD CS5535 companion chip
+endef
+
+$(eval $(call KernelPackage,cs5535))
+
+
+define KernelPackage/cs5536
+ TITLE:=AMD CS5536 chipset support
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_BLK_DEV_CS5536
+ FILES=$(LINUX_DIR)/drivers/ide/cs5536.ko
+ AUTOLOAD:=$(call AutoLoad,30,cs5536,1)
+ $(call AddDepends/ide)
+endef
+
+define KernelPackage/cs5536/description
+ Kernel module for the AMD CS5536 Geode LX companion chip
+endef
+
+$(eval $(call KernelPackage,cs5536))
+
+
+define KernelPackage/pata-cs5535
+ TITLE:=CS5535 PATA support
+ DEPENDS:=@TARGET_x86 @PCI_SUPPORT
+ KCONFIG:=CONFIG_PATA_CS5535
+ FILES=$(LINUX_DIR)/drivers/ata/pata-cs5535.ko
+ AUTOLOAD:=$(call AutoLoad,30,pata-cs5535,1)
+ $(call AddDepends/ata)
+endef
+
+define KernelPackage/cs5535/description
+ Kernel module for the NSC/AMD CS5535 companion chip
+endef
+
+$(eval $(call KernelPackage,cs5535))
+
+
+define KernelPackage/pata-cs5536
+ TITLE:=CS5536 PATA support
+ DEPENDS:=@TARGET_x86 @PCI_SUPPORT
+ KCONFIG:=CONFIG_PATA_CS5536
+ FILES=$(LINUX_DIR)/drivers/ata/pata-cs5536.ko
+ AUTOLOAD:=$(call AutoLoad,30,pata-cs5536,1)
+ $(call AddDepends/ata)
+endef
+
+define KernelPackage/cs5536/description
+ Kernel module for the AMD CS5536 Geode LX companion chip
+endef
+
+$(eval $(call KernelPackage,cs5536))
+
+
define KernelPackage/libsas
SUBMENU:=$(BLOCK_MENU)
TITLE:=SAS Domain Transport Attributes
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 3e17dc345d..b46e56eb63 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -519,7 +519,7 @@ $(eval $(call KernelPackage,ssb))
define KernelPackage/wdt-geode
SUBMENU:=$(OTHER_MENU)
TITLE:=Geode/LX Watchdog timer
- DEPENDS:=@TARGET_x86
+ DEPENDS:=@TARGET_x86 +kmod-cs5535-mfgpt
KCONFIG:=CONFIG_GEODE_WDT
FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/geodewdt.ko
AUTOLOAD:=$(call AutoLoad,50,geodewdt)
@@ -532,6 +532,38 @@ endef
$(eval $(call KernelPackage,wdt-geode))
+define KernelPackage/cs5535-clockevt
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=CS5535/CS5536 high-res timer (MFGPT) events
+ DEPENDS:=@TARGET_x86 +kmod-cs5535-mfgpt
+ KCONFIG:=CONFIG_CS5535_CLOCK_EVENT_SRC
+ FILES:=$(LINUX_DIR)/drivers/clocksource/cs5535-clockevt.ko
+ AUTOLOAD:=$(call AutoLoad,50,cs5535-clockevt)
+endef
+
+define KernelPackage/cs5535-clockevt/description
+ Kernel module for CS5535/6 high-res clock event source
+endef
+
+$(eval $(call KernelPackage,cs5535-clockevt))
+
+
+define KernelPackage/cs5535-mfgpt
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=CS5535/6 Multifunction General Purpose Timer
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_CS5535_MFGPT
+ FILES:=$(LINUX_DIR)/drivers/misc/cs5535-mfgpt.ko
+ AUTOLOAD:=$(call AutoLoad,45,cs5535-mfgpt)
+endef
+
+define KernelPackage/cs5535-mfgpt/description
+ Kernel module for CS5535/6 multifunction general purpose timer.
+endef
+
+$(eval $(call KernelPackage,cs5535-mfgpt))
+
+
define KernelPackage/wdt-omap
SUBMENU:=$(OTHER_MENU)
TITLE:=OMAP Watchdog timer