summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-03-18 18:44:30 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-03-18 18:44:30 +0000
commit662551d3a413bf8ac9014d042e545d2927886757 (patch)
tree3a381bf8fabf3eea3be739b98d903589cf256b40 /package/kernel
parentbea4837dc17bd55ca60eb5099992dbe92a8d1fce (diff)
downloadmaster-31e0f0ae-662551d3a413bf8ac9014d042e545d2927886757.tar.gz
master-31e0f0ae-662551d3a413bf8ac9014d042e545d2927886757.tar.bz2
master-31e0f0ae-662551d3a413bf8ac9014d042e545d2927886757.zip
kernel: add kmod-ata-sis (#8259)
SVN-Revision: 30978
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/block.mk16
1 files changed, 15 insertions, 1 deletions
diff --git a/package/kernel/modules/block.mk b/package/kernel/modules/block.mk
index a3a44b200c..357f5fd2eb 100644
--- a/package/kernel/modules/block.mk
+++ b/package/kernel/modules/block.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -166,6 +166,20 @@ endef
$(eval $(call KernelPackage,ata-sil24))
+define KernelPackage/ata-sis
+ TITLE:=SIS SATA support
+ KCONFIG:=CONFIG_SATA_SIS
+ FILES:=$(LINUX_DIR)/drivers/ata/sata_sis.ko
+ AUTOLOAD:=$(call AutoLoad,41,sata_sis,1)
+endef
+
+define KernelPackage/ata-sis/description
+ Support for SIS Serial ATA controllers.
+endef
+
+$(eval $(call KernelPackage,ata-sis))
+
+
define KernelPackage/ata-via-sata
TITLE:=VIA SATA support
KCONFIG:=CONFIG_SATA_VIA