summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-04-03 10:00:36 +0000
committerJohn Crispin <john@openwrt.org>2013-04-03 10:00:36 +0000
commit62b5098b35f0dac0e95487ba6a6283aae4f276c0 (patch)
tree30297090e6b4a6b00935492aeb39c4a079450320 /package/kernel
parentc9254f5b5d1fb36ae754a54a0f212d75b457959a (diff)
downloadmaster-31e0f0ae-62b5098b35f0dac0e95487ba6a6283aae4f276c0.tar.gz
master-31e0f0ae-62b5098b35f0dac0e95487ba6a6283aae4f276c0.tar.bz2
master-31e0f0ae-62b5098b35f0dac0e95487ba6a6283aae4f276c0.zip
add pcf857x kernel module
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 36180
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index f9937bee47..d1c21572d5 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -146,6 +146,21 @@ endef
$(eval $(call KernelPackage,gpio-nxp-74hc164))
+define KernelPackage/gpio-pcf857x
+ SUBMENU:=$(OTHER_MENU)
+ DEPENDS:=@GPIO_SUPPORT +kmod-i2c-core
+ TITLE:=PCX857x, PCA967x and MAX732X I2C GPIO expanders
+ KCONFIG:=CONFIG_GPIO_PCF857X
+ FILES:=$(LINUX_DIR)/drivers/gpio/gpio-pcf857x.ko
+ AUTOLOAD:=$(call AutoLoad,55,gpio-pcf857x)
+endef
+
+define KernelPackage/gpio-pcf857x/description
+ Kernel module for PCF857x, PCA{85,96}7x, and MAX732[89] I2C GPIO expanders
+endef
+
+$(eval $(call KernelPackage,gpio-pcf857x))
+
define KernelPackage/lp
SUBMENU:=$(OTHER_MENU)
TITLE:=Parallel port and line printer support