summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-03-18 19:49:22 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-03-18 19:49:22 +0000
commit60b39b7fc0a15580e03aa85b900ab133776a606e (patch)
tree4d5485d551c6af18817ddfb0817ce6143f3f2585 /package/kernel
parenta0e9402b46fa0fb110629e1fe2f145342ac378e1 (diff)
downloadmaster-31e0f0ae-60b39b7fc0a15580e03aa85b900ab133776a606e.tar.gz
master-31e0f0ae-60b39b7fc0a15580e03aa85b900ab133776a606e.tar.bz2
master-31e0f0ae-60b39b7fc0a15580e03aa85b900ab133776a606e.zip
Add support for the 8250 UART module.
It has been added at the end of other.mk as i couldn't find a better place for it. Signed-off-by: Christian Gagneraud <chris@techworks.ie> SVN-Revision: 30989
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 23d558c955..b57d055d36 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -872,3 +872,21 @@ endef
$(eval $(call KernelPackage,nandsim))
+define KernelPackage/serial-8250
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=8250 UARTs
+ KCONFIG:= CONFIG_SERIAL_8250 \
+ CONFIG_SERIAL_8250_NR_UARTS=16 \
+ CONFIG_SERIAL_8250_RUNTIME_UARTS=16 \
+ CONFIG_SERIAL_8250_EXTENDED=y \
+ CONFIG_SERIAL_8250_MANY_PORTS=y \
+ CONFIG_SERIAL_8250_SHARE_IRQ=y
+ FILES:=$(LINUX_DIR)/drivers/tty/serial/8250.ko
+endef
+
+define KernelPackage/serial-8250/description
+ Kernel module for 8250 UART based serial ports.
+endef
+
+$(eval $(call KernelPackage,serial-8250))
+