summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-07-17 08:50:19 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-07-17 08:50:19 +0000
commit57d2e57b02a009593a80ffa6af02841acc2541b6 (patch)
tree18932713fb38c23384bb35830181469dd4901bd8 /package/kernel
parent15da77bdedb15082693655e3a38fea6944c85872 (diff)
downloadmaster-31e0f0ae-57d2e57b02a009593a80ffa6af02841acc2541b6.tar.gz
master-31e0f0ae-57d2e57b02a009593a80ffa6af02841acc2541b6.tar.bz2
master-31e0f0ae-57d2e57b02a009593a80ffa6af02841acc2541b6.zip
finalize r22241 fixes
SVN-Revision: 22242
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/netfilter.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/kernel/modules/netfilter.mk b/package/kernel/modules/netfilter.mk
index 3ce557aa5b..84f746f9c5 100644
--- a/package/kernel/modules/netfilter.mk
+++ b/package/kernel/modules/netfilter.mk
@@ -514,11 +514,12 @@ endef
$(eval $(call KernelPackage,nf-conntrack-netlink))
define KernelPackage/ipt-hashlimit
-$(call KernelPackage/ipt/Depends,)
+ SUBMENU:=$(NF_MENU)
TITLE:=Netfilter hashlimit match
- FILES:=$(LINUX_DIR)/net/netfilter/xt_hashlimit.ko
KCONFIG:=$(KCONFIG_IPT_HASHLIMIT)
+ FILES:=$(LINUX_DIR)/net/netfilter/xt_hashlimit.ko
AUTOLOAD:=$(call AutoLoad,50,xt_hashlimit)
+ $(call KernelPackage/ipt)
endef
define KernelPackage/ipt-hashlimit/description