summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-03-10 15:41:04 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-03-10 15:41:04 +0000
commit395bd8bf6052925733069a2833b8a5c2a661ea7c (patch)
tree6c4e43cb906dfbabf36a706531b9de6506a71767 /package/kernel
parent734b8cb2172d02a0bd8fa3e69fef44be7107359c (diff)
downloadmaster-31e0f0ae-395bd8bf6052925733069a2833b8a5c2a661ea7c.tar.gz
master-31e0f0ae-395bd8bf6052925733069a2833b8a5c2a661ea7c.tar.bz2
master-31e0f0ae-395bd8bf6052925733069a2833b8a5c2a661ea7c.zip
kernel: further fixes to kmod-gre packaging
SVN-Revision: 26012
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/netsupport.mk14
1 files changed, 8 insertions, 6 deletions
diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index 25e2ac42c2..0116283045 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -370,12 +370,14 @@ $(eval $(call KernelPackage,ip6-tunnel))
define KernelPackage/gre
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=GRE support
- KCONFIG:=CONFIG_NET_IPGRE \
- $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),CONFIG_NET_IPGRE_DEMUX)
- FILES=$(LINUX_DIR)/net/ipv4/ip_gre.ko \
- $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),$(LINUX_DIR)/net/ipv4/gre.ko)
- AUTOLOAD:=$(call AutoLoad,39, \
- $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),gre) ip_gre)
+ KCONFIG:=CONFIG_NET_IPGRE CONFIG_NET_IPGRE_DEMUX
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),1)
+ FILES:=$(LINUX_DIR)/net/ipv4/ip_gre.ko $(LINUX_DIR)/net/ipv4/gre.ko
+ AUTOLOAD:=$(call AutoLoad,39,gre ip_gre)
+ else
+ FILES:=$(LINUX_DIR)/net/ipv4/ip_gre.ko
+ AUTOLOAD:=$(call AutoLoad,39,ip_gre)
+ endif
endef
define KernelPackage/gre/description