summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorDaniel Dickinson <crazycshore@gmail.com>2011-07-03 03:14:58 +0000
committerDaniel Dickinson <crazycshore@gmail.com>2011-07-03 03:14:58 +0000
commit2e4d84278eabce6f7c6fd04ba7710735e31fb54b (patch)
tree6e50637c6ac4751f0441501632081eb04580e5c8 /package/kernel
parentb0cc0067f9ca5e8245160919ecf3d52a2d5ad0e3 (diff)
downloadmaster-31e0f0ae-2e4d84278eabce6f7c6fd04ba7710735e31fb54b.tar.gz
master-31e0f0ae-2e4d84278eabce6f7c6fd04ba7710735e31fb54b.tar.bz2
master-31e0f0ae-2e4d84278eabce6f7c6fd04ba7710735e31fb54b.zip
package/kernel/modules: Alexandros pointed me at this patch, and I noted that not only the MFGPT module but also the new GPIO driver both rely on the mfd_core functionality to operate correctly.
Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com> Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com> SVN-Revision: 27372
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk22
1 files changed, 20 insertions, 2 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 2b6b86bfc1..2de923f952 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -127,7 +127,7 @@ $(eval $(call KernelPackage,gpio-cs5535))
define KernelPackage/gpio-cs5535-new
SUBMENU:=$(OTHER_MENU)
TITLE:=AMD CS5535/CS5536 GPIO driver with improved sysfs support
- DEPENDS:=@TARGET_x86 @!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32)
+ DEPENDS:=@TARGET_x86 +kmod-cs5535-mfd @!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32)
KCONFIG:=CONFIG_GPIO_CS5535
FILES:=$(LINUX_DIR)/drivers/gpio/cs5535-gpio.ko
AUTOLOAD:=$(call AutoLoad,50,cs5535-gpio)
@@ -552,7 +552,7 @@ $(eval $(call KernelPackage,cs5535-clockevt))
define KernelPackage/cs5535-mfgpt
SUBMENU:=$(OTHER_MENU)
TITLE:=CS5535/6 Multifunction General Purpose Timer
- DEPENDS:=@TARGET_x86
+ DEPENDS:=@TARGET_x86 +kmod-cs5535-mfd
KCONFIG:=CONFIG_CS5535_MFGPT
FILES:=$(LINUX_DIR)/drivers/misc/cs5535-mfgpt.ko
AUTOLOAD:=$(call AutoLoad,45,cs5535-mfgpt)
@@ -565,6 +565,24 @@ endef
$(eval $(call KernelPackage,cs5535-mfgpt))
+define KernelPackage/cs5535-mfd
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=CS5535/6 Multifunction General Purpose Driver
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_MFD_CS5535
+ FILES:= \
+ $(LINUX_DIR)/drivers/mfd/mfd-core.ko \
+ $(LINUX_DIR)/drivers/mfd/cs5535-mfd.ko
+ AUTOLOAD:=$(call AutoLoad,44,mfd-core cs5535-mfd)
+endef
+
+define KernelPackage/cs5535-mfd/description
+ Core driver for CS5535/CS5536 MFD functions.
+endef
+
+$(eval $(call KernelPackage,cs5535-mfd))
+
+
define KernelPackage/wdt-omap
SUBMENU:=$(OTHER_MENU)
TITLE:=OMAP Watchdog timer