summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-25 15:49:46 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-25 15:49:46 +0000
commit276bc6b9e8015801c5933d015e3f657c6fc28ed2 (patch)
treefd349c70101a2ac6acb2e3a026ecc36c6ed51fd3 /package/kernel
parentd973768580c219115f2e8147fa74bb6dcc74f5ea (diff)
downloadmaster-31e0f0ae-276bc6b9e8015801c5933d015e3f657c6fc28ed2.tar.gz
master-31e0f0ae-276bc6b9e8015801c5933d015e3f657c6fc28ed2.tar.bz2
master-31e0f0ae-276bc6b9e8015801c5933d015e3f657c6fc28ed2.zip
fix libsas and mvsas dependencies against PCI and not x86
SVN-Revision: 32847
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/block.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/kernel/modules/block.mk b/package/kernel/modules/block.mk
index cdf3effc5a..819b748b53 100644
--- a/package/kernel/modules/block.mk
+++ b/package/kernel/modules/block.mk
@@ -492,7 +492,6 @@ $(eval $(call KernelPackage,ide-it821x))
define KernelPackage/libsas
SUBMENU:=$(BLOCK_MENU)
TITLE:=SAS Domain Transport Attributes
- DEPENDS:=@TARGET_x86
KCONFIG:=CONFIG_SCSI_SAS_LIBSAS \
CONFIG_SCSI_SAS_ATTRS \
CONFIG_SCSI_SAS_ATA=y \
@@ -531,7 +530,7 @@ $(eval $(call KernelPackage,loop))
define KernelPackage/mvsas
SUBMENU:=$(BLOCK_MENU)
TITLE:=Marvell 88SE6440 SAS/SATA driver
- DEPENDS:=@TARGET_x86 +kmod-libsas
+ DEPENDS:=@PCI_SUPPORT +kmod-libsas
KCONFIG:= \
CONFIG_SCSI_MVSAS \
CONFIG_SCSI_MVSAS_TASKLET=n