summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-02-16 18:28:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-02-16 18:28:55 +0000
commit19d6a9ce6ab828e63a00b4564d577a153b7743fa (patch)
treed93ce0c9b58218ec03348debf48d35ff25590447 /package/kernel
parenteca17a4a28d3f711fae1924bbc9066db677743b1 (diff)
downloadmaster-31e0f0ae-19d6a9ce6ab828e63a00b4564d577a153b7743fa.tar.gz
master-31e0f0ae-19d6a9ce6ab828e63a00b4564d577a153b7743fa.tar.bz2
master-31e0f0ae-19d6a9ce6ab828e63a00b4564d577a153b7743fa.zip
kernel: add a package for block2mtd
SVN-Revision: 19665
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 47fee9f53c..ada8365a7f 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -7,6 +7,14 @@
OTHER_MENU:=Other modules
+define KernelPackage/block2mtd
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Block device MTD emulation
+ KCONFIG:=CONFIG_MTD_BLOCK2MTD
+ FILES:=$(LINUX_DIR)/drivers/mtd/devices/block2mtd.$(LINUX_KMOD_SUFFIX)
+endef
+$(eval $(call KernelPackage,block2mtd))
+
define KernelPackage/crc-itu-t
SUBMENU:=$(OTHER_MENU)
TITLE:=CRC ITU-T V.41 support