summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-07-25 23:41:22 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-07-25 23:41:22 +0000
commit18b5b6d1ce3dbc0652b9ed2b1ce762ef17963a12 (patch)
tree1e3c5c8f2cf9bfb0733fe6b0027c1617a53db6a7 /package/kernel
parentdc506df09305120cbe2f2b997b58b82acf88b3f0 (diff)
downloadmaster-31e0f0ae-18b5b6d1ce3dbc0652b9ed2b1ce762ef17963a12.tar.gz
master-31e0f0ae-18b5b6d1ce3dbc0652b9ed2b1ce762ef17963a12.tar.bz2
master-31e0f0ae-18b5b6d1ce3dbc0652b9ed2b1ce762ef17963a12.zip
add support for the sn9c102 video chips (#3976)
SVN-Revision: 16991
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/video.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/modules/video.mk b/package/kernel/modules/video.mk
index 5fd008bb70..f8b7a491ca 100644
--- a/package/kernel/modules/video.mk
+++ b/package/kernel/modules/video.mk
@@ -126,6 +126,24 @@ endef
$(eval $(call KernelPackage,video-ovcamchip))
+define KernelPackage/video-sn9c102
+ SUBMENU:=$(VIDEO_MENU)
+ TITLE:=SN9C102 Camera Chip support
+ DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-core +kmod-video-core
+ KCONFIG:=CONFIG_USB_SN9C102
+ FILES:=$(LINUX_DIR)/drivers/media/video/sn9c102/sn9c102.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,70,sn9c102)
+endef
+
+
+define KernelPackage/video-sn9c102/description
+ Kernel modules for supporting SN9C102
+ camera chips.
+endef
+
+$(eval $(call KernelPackage,video-sn9c102))
+
+
define KernelPackage/video-pwc
SUBMENU:=$(VIDEO_MENU)
TITLE:=Philips USB webcam support