summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorMatteo Croce <matteo.croce@canonical.com>2016-06-22 15:15:10 +0200
committerFelix Fietkau <nbd@nbd.name>2016-08-11 10:45:33 +0200
commit1645abffea2785653de27d92ba0e977d1f32a538 (patch)
treed47dc4f73bdf87a24e1ea84dbf9a9d7b8b67faf4 /package/kernel
parentdff6df962556b2f2fed0797a4d0d115dc68e90cb (diff)
downloadmaster-31e0f0ae-1645abffea2785653de27d92ba0e977d1f32a538.tar.gz
master-31e0f0ae-1645abffea2785653de27d92ba0e977d1f32a538.tar.bz2
master-31e0f0ae-1645abffea2785653de27d92ba0e977d1f32a538.zip
kernel: add plan 9 fs package
9pfs is used by kvm to share files between host and guest, add proper config option to enable it. Signed-off-by: Matteo Croce <matteo.croce@canonical.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/fs.mk18
-rw-r--r--package/kernel/linux/modules/netsupport.mk21
2 files changed, 39 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 52fa47a68b..e8e1f80da0 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -26,6 +26,24 @@ endef
$(eval $(call KernelPackage,fs-fscache))
+define KernelPackage/fs-9p
+ SUBMENU:=$(FS_MENU)
+ TITLE:=Plan 9 Resource Sharing Support
+ DEPENDS:=+kmod-9pnet
+ KCONFIG:=\
+ CONFIG_9P_FS \
+ CONFIG_9P_FS_POSIX_ACL=n \
+ CONFIG_9P_FS_SECURITY=n
+ FILES:=$(LINUX_DIR)/fs/9p/9p.ko
+ AUTOLOAD:=$(call AutoLoad,30,9p)
+endef
+
+define KernelPackage/fs-9p/description
+ Kernel module for Plan 9 Resource Sharing Support support
+endef
+
+$(eval $(call KernelPackage,fs-9p))
+
define KernelPackage/fs-afs
SUBMENU:=$(FS_MENU)
TITLE:=Andrew FileSystem client
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index cf1de6a894..c68be90ad2 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -1015,3 +1015,24 @@ define KernelPackage/mpls/description
endef
$(eval $(call KernelPackage,mpls))
+
+define KernelPackage/9pnet
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=Plan 9 Resource Sharing Support (9P2000)
+ DEPENDS:=@VIRTIO_SUPPORT
+ KCONFIG:= \
+ CONFIG_NET_9P \
+ CONFIG_NET_9P_DEBUG=n \
+ CONFIG_NET_9P_VIRTIO
+ FILES:= \
+ $(LINUX_DIR)/net/9p/9pnet.ko \
+ $(LINUX_DIR)/net/9p/9pnet_virtio.ko
+ AUTOLOAD:=$(call AutoLoad,29,9pnet 9pnet_virtio)
+endef
+
+define KernelPackage/9pnet/description
+ Kernel support support for
+ Plan 9 resource sharing via the 9P2000 protocol.
+endef
+
+$(eval $(call KernelPackage,9pnet))