summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-29 08:12:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-29 08:12:31 +0000
commit0b39a6d4e95c1969550eea89238a2f7c34433be2 (patch)
tree1e506740009c1b3453ec7af70cbfc00a70fa24e4 /package/kernel
parentb2f3e852d0e42ee29f38c15033fadb736383bae1 (diff)
downloadmaster-31e0f0ae-0b39a6d4e95c1969550eea89238a2f7c34433be2.tar.gz
master-31e0f0ae-0b39a6d4e95c1969550eea89238a2f7c34433be2.tar.bz2
master-31e0f0ae-0b39a6d4e95c1969550eea89238a2f7c34433be2.zip
kernel: remove useless AddDepends/hid abstraction
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45134
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/001-depends.mk4
-rw-r--r--package/kernel/linux/modules/input.mk2
-rw-r--r--package/kernel/linux/modules/other.mk3
-rw-r--r--package/kernel/linux/modules/usb.mk2
4 files changed, 3 insertions, 8 deletions
diff --git a/package/kernel/linux/modules/001-depends.mk b/package/kernel/linux/modules/001-depends.mk
index e845670ec8..57fc9abf73 100644
--- a/package/kernel/linux/modules/001-depends.mk
+++ b/package/kernel/linux/modules/001-depends.mk
@@ -5,10 +5,6 @@
# See /LICENSE for more information.
#
-define AddDepends/hid
- DEPENDS+= +kmod-hid $(1)
-endef
-
define AddDepends/input
DEPENDS+= +kmod-input-core $(1)
endef
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 2320b051f9..1e8b2f0257 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -25,10 +25,10 @@ $(eval $(call KernelPackage,hid))
define KernelPackage/hid-generic
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=Generic HID device support
+ DEPENDS:=+kmod-hid
KCONFIG:=CONFIG_HID_GENERIC
FILES:=$(LINUX_DIR)/drivers/hid/hid-generic.ko
AUTOLOAD:=$(call AutoProbe,hid-generic)
- $(call AddDepends/hid)
endef
define KernelPackage/hid/description
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 1644f77ce4..c270481932 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -29,7 +29,7 @@ $(eval $(call KernelPackage,6lowpan-iphc))
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +!LINUX_3_10:kmod-6lowpan-iphc +kmod-lib-crc16
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +!LINUX_3_10:kmod-6lowpan-iphc +kmod-lib-crc16 +kmod-hid
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \
@@ -50,7 +50,6 @@ define KernelPackage/bluetooth
CONFIG_BT_HCIUART_H4 \
CONFIG_BT_HIDP \
CONFIG_HID_SUPPORT=y
- $(call AddDepends/hid)
$(call AddDepends/rfkill)
FILES:= \
$(LINUX_DIR)/net/bluetooth/bluetooth.ko \
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 74d9e6f1ec..ef803f3eb3 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1311,10 +1311,10 @@ $(eval $(call KernelPackage,usb-net-kalmia))
define KernelPackage/usb-hid
TITLE:=Support for USB Human Input Devices
KCONFIG:=CONFIG_HID_SUPPORT=y CONFIG_USB_HID CONFIG_USB_HIDDEV=y
+ DEPENDS:=+kmod-hid +kmod-hid-generic
FILES:=$(LINUX_DIR)/drivers/$(USBHID_DIR)/usbhid.ko
AUTOLOAD:=$(call AutoProbe,usbhid)
$(call AddDepends/usb)
- $(call AddDepends/hid,+kmod-hid-generic)
$(call AddDepends/input,+kmod-input-evdev)
endef