summaryrefslogtreecommitdiffstats
path: root/package/kernel/mwlwifi
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-03-23 12:45:19 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-03-23 12:45:19 +0000
commita86b430a8502af6b82eef213feefdf6d72a21063 (patch)
tree480edf853288148a1337ec7444d493b5e6c0d1c8 /package/kernel/mwlwifi
parent5be4f2b5b84656223f2b3d7bf6cfed8150ef4164 (diff)
downloadmaster-31e0f0ae-a86b430a8502af6b82eef213feefdf6d72a21063.tar.gz
master-31e0f0ae-a86b430a8502af6b82eef213feefdf6d72a21063.tar.bz2
master-31e0f0ae-a86b430a8502af6b82eef213feefdf6d72a21063.zip
mwlwifi: update to the new revision
Adds client mode support and fixes for Apple devices Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 44950
Diffstat (limited to 'package/kernel/mwlwifi')
-rw-r--r--package/kernel/mwlwifi/Makefile10
-rw-r--r--package/kernel/mwlwifi/patches/001-pwrtable_path.patch11
2 files changed, 5 insertions, 16 deletions
diff --git a/package/kernel/mwlwifi/Makefile b/package/kernel/mwlwifi/Makefile
index 611e77240a..29096d5dd2 100644
--- a/package/kernel/mwlwifi/Makefile
+++ b/package/kernel/mwlwifi/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2014 OpenWrt.org
+# Copyright (C) 2014-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mwlwifi
-PKG_VERSION:=10.2.6.1.p4-20141228
+PKG_VERSION:=10.2.8.5.p0-20150320
PKG_RELEASE=1
PKG_LICENSE:=ISC
@@ -17,7 +17,7 @@ PKG_LICENSE_FILES:=
PKG_SOURCE_URL:=https://github.com/kaloz/mwlwifi
PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=f92c46695d92dc23606d65bb32611e92235c30fc
+PKG_SOURCE_VERSION:=4774b30dce69a8e97c9431e2dc920ea92b5a976c
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
PKG_MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
@@ -53,8 +53,8 @@ endef
define KernelPackage/mwlwifi/install
$(INSTALL_DIR) $(1)/lib/firmware
- $(CP) $(PKG_BUILD_DIR)/bin/firmware/7.2.6.1/88W8864.bin $(1)/lib/firmware/
- $(CP) $(PKG_BUILD_DIR)/bin/powertable/Mamba/Mamba_FCC_v1.2_5G4TX.ini $(1)/lib/firmware/
+ $(INSTALL_DIR) $(1)/lib/firmware/mwlwifi
+ $(CP) $(PKG_BUILD_DIR)/bin/firmware/88W8864.bin $(1)/lib/firmware/mwlwifi/
endef
$(eval $(call KernelPackage,mwlwifi))
diff --git a/package/kernel/mwlwifi/patches/001-pwrtable_path.patch b/package/kernel/mwlwifi/patches/001-pwrtable_path.patch
deleted file mode 100644
index 99c4ba6bdb..0000000000
--- a/package/kernel/mwlwifi/patches/001-pwrtable_path.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/mwl_main.c
-+++ b/mwl_main.c
-@@ -72,7 +72,7 @@ static long atohex2(const char *number);
- */
-
- static char fw_image_path[FILE_PATH_LEN] = "88W8864.bin";
--static char pwr_tbl_path[FILE_PATH_LEN] = "PWR_TABLE.ini";
-+static char pwr_tbl_path[FILE_PATH_LEN] = "/lib/firmware/Mamba_FCC_v1.2_5G4TX.ini";
-
- static struct pci_device_id mwl_pci_id_tbl[SYSADPT_MAX_CARDS_SUPPORT + 1] = {
-