summaryrefslogtreecommitdiffstats
path: root/package/kernel/mt76
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-08 21:46:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-08 21:46:42 +0000
commit3f4011ad367cc4bd5d0734cded64bd8527f021d9 (patch)
treeb6917e740c210873eee45c7997a0c0fb931694bd /package/kernel/mt76
parent3209b13b3fc656f37d68be9ad7a6671008cea4bf (diff)
downloadmaster-31e0f0ae-3f4011ad367cc4bd5d0734cded64bd8527f021d9.tar.gz
master-31e0f0ae-3f4011ad367cc4bd5d0734cded64bd8527f021d9.tar.bz2
master-31e0f0ae-3f4011ad367cc4bd5d0734cded64bd8527f021d9.zip
mt76: include generated mac80211 config file and add an appropriate define for mesh support (fixes #19474)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45649
Diffstat (limited to 'package/kernel/mt76')
-rw-r--r--package/kernel/mt76/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/kernel/mt76/Makefile b/package/kernel/mt76/Makefile
index 31cd1208cb..561f6069b2 100644
--- a/package/kernel/mt76/Makefile
+++ b/package/kernel/mt76/Makefile
@@ -33,8 +33,13 @@ NOSTDINC_FLAGS = \
-I$(STAGING_DIR)/usr/include/mac80211-backport \
-I$(STAGING_DIR)/usr/include/mac80211/uapi \
-I$(STAGING_DIR)/usr/include/mac80211 \
+ -include backport/autoconf.h \
-include backport/backport.h
+ifdef CONFIG_PACKAGE_MAC80211_MESH
+ NOSTDINC_FLAGS += -DCONFIG_MAC80211_MESH
+endif
+
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C "$(LINUX_DIR)" \
ARCH="$(LINUX_KARCH)" \