summaryrefslogtreecommitdiffstats
path: root/package/kernel/modules
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-02-14 20:11:28 +0000
committerJohn Crispin <john@openwrt.org>2012-02-14 20:11:28 +0000
commit6c5d3e0844077cb2b4dc9c02ba8b909611e223d2 (patch)
treee36f3ddfaad244d0baaedb1d158e7b2b0ec48dc1 /package/kernel/modules
parent23b2bd9494626b9cefda44459f11927da64695a5 (diff)
downloadmaster-31e0f0ae-6c5d3e0844077cb2b4dc9c02ba8b909611e223d2.tar.gz
master-31e0f0ae-6c5d3e0844077cb2b4dc9c02ba8b909611e223d2.tar.bz2
master-31e0f0ae-6c5d3e0844077cb2b4dc9c02ba8b909611e223d2.zip
add missing autoload shortcut to crypto modules for btrfs
Currently the btrfs module (and other fs modules) is loaded before other modules to provide early extroot compatibility. This will fail for btrfs however, because the dependencies crypto-core and crypto-hash are missing. This patch makes them available for early loading too. Signed-off-by: Jan Willies <jan@willies.info> SVN-Revision: 30542
Diffstat (limited to 'package/kernel/modules')
-rw-r--r--package/kernel/modules/crypto.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index 5459de382e..ef41d6f700 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -29,7 +29,7 @@ define KernelPackage/crypto-core
CONFIG_CRYPTO_ALGAPI \
$(foreach mod,$(CRYPTO_MODULES),$(call crypto_confvar,$(mod)))
FILES:=$(foreach mod,$(CRYPTO_MODULES),$(call crypto_file,$(mod)))
- AUTOLOAD:=$(call AutoLoad,01,$(foreach mod,$(CRYPTO_MODULES),$(call crypto_name,$(mod))))
+ AUTOLOAD:=$(call AutoLoad,01,$(foreach mod,$(CRYPTO_MODULES),$(call crypto_name,$(mod))),1)
endef
$(eval $(call KernelPackage,crypto-core))
@@ -43,7 +43,7 @@ define KernelPackage/crypto-hash
TITLE:=CryptoAPI hash support
KCONFIG:=CONFIG_CRYPTO_HASH2
FILES:=$(LINUX_DIR)/crypto/crypto_hash.ko
- AUTOLOAD:=$(call AutoLoad,02,crypto_hash)
+ AUTOLOAD:=$(call AutoLoad,02,crypto_hash,1)
$(call AddDepends/crypto)
endef
$(eval $(call KernelPackage,crypto-hash))