summaryrefslogtreecommitdiffstats
path: root/package/kernel/modules
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-09-04 18:06:49 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-09-04 18:06:49 +0000
commit573f15826d5e588ca2f57af0555036d9c4224206 (patch)
treee6684559d082a6d3fc51ea06807f89c60b7d82c6 /package/kernel/modules
parent54f4be5bd6f4e0abdac2edf72d0adc8ccde52c0f (diff)
downloadmaster-31e0f0ae-573f15826d5e588ca2f57af0555036d9c4224206.tar.gz
master-31e0f0ae-573f15826d5e588ca2f57af0555036d9c4224206.tar.bz2
master-31e0f0ae-573f15826d5e588ca2f57af0555036d9c4224206.zip
kmod-sctp: Add SCTP kernel support
This adds a new kmod-sctp option that enables support of SCTP in 2.6x kernels. The patch also contains a small cleanup in the dependencies. Signed-off-by: Sebastien Decugis <sdecugis@nict.go.jp> SVN-Revision: 22917
Diffstat (limited to 'package/kernel/modules')
-rw-r--r--package/kernel/modules/fs.mk7
-rw-r--r--package/kernel/modules/netsupport.mk22
-rw-r--r--package/kernel/modules/other.mk16
3 files changed, 40 insertions, 5 deletions
diff --git a/package/kernel/modules/fs.mk b/package/kernel/modules/fs.mk
index 71b1a59fcd..e5714aab64 100644
--- a/package/kernel/modules/fs.mk
+++ b/package/kernel/modules/fs.mk
@@ -25,16 +25,13 @@ $(eval $(call KernelPackage,fs-autofs4))
define KernelPackage/fs-btrfs
SUBMENU:=$(FS_MENU)
TITLE:=BTRFS filesystem support
- # for crc32c
- DEPENDS:=+kmod-crypto-core +kmod-crypto-misc
+ DEPENDS:=+kmod-libcrc32c
KCONFIG:=\
- CONFIG_LIBCRC32C \
CONFIG_BTRFS_FS \
CONFIG_BTRFS_FS_POSIX_ACL=n
FILES:=\
- $(LINUX_DIR)/lib/libcrc32c.ko \
$(LINUX_DIR)/fs/btrfs/btrfs.ko
- AUTOLOAD:=$(call AutoLoad,30,crc32c libcrc32c btrfs,1)
+ AUTOLOAD:=$(call AutoLoad,30,btrfs,1)
endef
define KernelPackage/fs-btrfs/description
diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index 196e5a39c8..703cc648ca 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -674,3 +674,25 @@ endef
$(eval $(call KernelPackage,l2tp-ip))
+define KernelPackage/sctp
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=SCTP protocol kernel support
+ KCONFIG:=\
+ CONFIG_IP_SCTP \
+ CONFIG_SCTP_DBG_MSG=n \
+ CONFIG_SCTP_DBG_OBJCNT=n \
+ CONFIG_SCTP_HMAC_NONE=n \
+ CONFIG_SCTP_HMAC_SHA1=n \
+ CONFIG_SCTP_HMAC_MD5=y
+ FILES:= $(LINUX_DIR)/net/sctp/sctp.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:= $(call AutoLoad,32,sctp)
+ DEPENDS:=+kmod-libcrc32c +kmod-crypto-md5 +kmod-crypto-hmac
+endef
+
+define KernelPackage/sctp/description
+ Kernel modules for SCTP protocol support
+endef
+
+$(eval $(call KernelPackage,sctp))
+
+
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 18cd79faf9..53080f8cdf 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -132,6 +132,22 @@ endef
$(eval $(call KernelPackage,crc16))
+define KernelPackage/libcrc32c
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=CRC32 library support
+ KCONFIG:=CONFIG_LIBCRC32C
+ DEPENDS:=+kmod-crypto-core +kmod-crypto-misc
+ FILES:=$(LINUX_DIR)/lib/libcrc32c.ko
+ AUTOLOAD:=$(call AutoLoad,20,crc32c libcrc32c,1)
+endef
+
+define KernelPackage/libcrc32c/description
+ Kernel module for CRC32 support
+endef
+
+$(eval $(call KernelPackage,libcrc32c))
+
+
define KernelPackage/eeprom-93cx6
SUBMENU:=$(OTHER_MENU)
TITLE:=EEPROM 93CX6 support