summaryrefslogtreecommitdiffstats
path: root/package/kernel/modules
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2007-12-31 13:33:54 +0000
committerJohn Crispin <john@openwrt.org>2007-12-31 13:33:54 +0000
commit16664379f2471def79a00cddee45c29e149d7238 (patch)
tree82f34dd92bc7d49005c10548bfc82b5bdbd8f046 /package/kernel/modules
parent415a070cd22b9110a06dddb27daff266e96f1302 (diff)
downloadmaster-31e0f0ae-16664379f2471def79a00cddee45c29e149d7238.tar.gz
master-31e0f0ae-16664379f2471def79a00cddee45c29e149d7238.tar.bz2
master-31e0f0ae-16664379f2471def79a00cddee45c29e149d7238.zip
add package for olpc sound module
SVN-Revision: 10067
Diffstat (limited to 'package/kernel/modules')
-rw-r--r--package/kernel/modules/sound.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/modules/sound.mk b/package/kernel/modules/sound.mk
index 11d816b366..2cf9b2154c 100644
--- a/package/kernel/modules/sound.mk
+++ b/package/kernel/modules/sound.mk
@@ -88,3 +88,17 @@ endef
$(eval $(call KernelPackage,sound-i8x0))
+define KernelPackage/sound-cs5535audio
+ SUBMENU:=$(SOUND_MENU)
+ TITLE:=CS5535 PCI Controller
+ DEPENDS:=kmod-sound-core
+ KCONFIG:=CONFIG_SND_CS5535AUDIO
+ FILES:=$(LINUX_DIR)/sound/pci/cs5535audio/snd-cs5535audio.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,35,snd-cs5535audio)
+endef
+
+define KernelPackage/sound-cs5535audio/description
+ support for the integrated AC97 sound device on olpc
+endef
+
+$(eval $(call KernelPackage,sound-cs5535audio))