summaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/spi.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-05-27 12:33:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-05-27 12:33:55 +0000
commitb85c7c117a6f26bc490d9a5ec8b6c137dcc59f6d (patch)
treea879eb0881b35cd88cceb3ff376c43ed59c1461e /package/kernel/modules/spi.mk
parentd7522444d25d5211a96073983b25f6a6e8992c3b (diff)
downloadmaster-31e0f0ae-b85c7c117a6f26bc490d9a5ec8b6c137dcc59f6d.tar.gz
master-31e0f0ae-b85c7c117a6f26bc490d9a5ec8b6c137dcc59f6d.tar.bz2
master-31e0f0ae-b85c7c117a6f26bc490d9a5ec8b6c137dcc59f6d.zip
kernel: remove a few more obsolete CompareKernelPatchVer calls, add dependencies on @TARGET_x86 for a few network drivers that are typically not found in non-PC equipment
SVN-Revision: 31870
Diffstat (limited to 'package/kernel/modules/spi.mk')
-rw-r--r--package/kernel/modules/spi.mk18
1 files changed, 4 insertions, 14 deletions
diff --git a/package/kernel/modules/spi.mk b/package/kernel/modules/spi.mk
index 0fac5a81ed..fc7bce559a 100644
--- a/package/kernel/modules/spi.mk
+++ b/package/kernel/modules/spi.mk
@@ -31,13 +31,8 @@ define KernelPackage/spi-bitbang
KCONFIG:=CONFIG_SPI_BITBANG \
CONFIG_SPI=y \
CONFIG_SPI_MASTER=y
- ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.1)),1)
- FILES:=$(LINUX_DIR)/drivers/spi/spi-bitbang.ko
- AUTOLOAD:=$(call AutoLoad,91,spi-bitbang)
- else
- FILES:=$(LINUX_DIR)/drivers/spi/spi_bitbang.ko
- AUTOLOAD:=$(call AutoLoad,91,spi_bitbang)
- endif
+ FILES:=$(LINUX_DIR)/drivers/spi/spi-bitbang.ko
+ AUTOLOAD:=$(call AutoLoad,91,spi-bitbang)
endef
define KernelPackage/spi-bitbang/description
@@ -67,13 +62,8 @@ define KernelPackage/spi-gpio
TITLE:=GPIO-based bitbanging SPI Master
DEPENDS:=@GPIO_SUPPORT +kmod-spi-bitbang
KCONFIG:=CONFIG_SPI_GPIO
- ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.1)),1)
- FILES:=$(LINUX_DIR)/drivers/spi/spi-gpio.ko
- AUTOLOAD:=$(call AutoLoad,92,spi-gpio)
- else
- FILES:=$(LINUX_DIR)/drivers/spi/spi_gpio.ko
- AUTOLOAD:=$(call AutoLoad,92,spi_gpio)
- endif
+ FILES:=$(LINUX_DIR)/drivers/spi/spi-gpio.ko
+ AUTOLOAD:=$(call AutoLoad,92,spi-gpio)
endef
define KernelPackage/spi-gpio/description