summaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/hwmon.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-09-30 12:55:30 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-09-30 12:55:30 +0000
commitcfc370eea08d557e590c6c378b9f191845352945 (patch)
treed8bdb93b72606a3b8f9b2d70e6c81134ec41c7cf /package/kernel/modules/hwmon.mk
parentd53022a42418ff04bbe6040c9808d14378de2660 (diff)
downloadmaster-31e0f0ae-cfc370eea08d557e590c6c378b9f191845352945.tar.gz
master-31e0f0ae-cfc370eea08d557e590c6c378b9f191845352945.tar.bz2
master-31e0f0ae-cfc370eea08d557e590c6c378b9f191845352945.zip
add kmod-hwmon-lm95241
This allows building the module for the national lm95241 i2c temperature sensor. Signed-off-by: Daniel Golle <dgolle@allnet.de> SVN-Revision: 28335
Diffstat (limited to 'package/kernel/modules/hwmon.mk')
-rw-r--r--package/kernel/modules/hwmon.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/modules/hwmon.mk b/package/kernel/modules/hwmon.mk
index ebbe7cfabc..57dd5684cb 100644
--- a/package/kernel/modules/hwmon.mk
+++ b/package/kernel/modules/hwmon.mk
@@ -89,6 +89,20 @@ endef
$(eval $(call KernelPackage,hwmon-lm90))
+define KernelPackage/hwmon-lm95241
+ TITLE:=LM95241 monitoring support
+ KCONFIG:=CONFIG_SENSORS_LM95241
+ FILES:=$(LINUX_DIR)/drivers/hwmon/lm95241.ko
+ AUTOLOAD:=$(call AutoLoad,60,lm95241)
+ $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-lm95241/description
+ Kernel module for LM95241 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm95241))
+
define KernelPackage/hwmon-pc87360
TITLE:=PC87360 monitoring support