summaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/crypto.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-05-03 21:22:43 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-05-03 21:22:43 +0000
commitbe2275b8e68e547285e2d2988647a4b096b0741a (patch)
treec8e08f0165089b29b277550e427090b6a820061e /package/kernel/modules/crypto.mk
parent3d0ac93274788ce16bad8d8d0c8d4a811ac3b08b (diff)
downloadmaster-31e0f0ae-be2275b8e68e547285e2d2988647a4b096b0741a.tar.gz
master-31e0f0ae-be2275b8e68e547285e2d2988647a4b096b0741a.tar.bz2
master-31e0f0ae-be2275b8e68e547285e2d2988647a4b096b0741a.zip
kernel: add kmod-crypto-ipsec kmod-crypto-ipsec bundles some otherwise unprovided kernel crypto modules that are useful for IPSEC. This is an alternative to breaking these modules out into kmod-crypto-wq (crypto_wq.ko), kmod-crypto-rng (rng.ko and krng.ko), and kmod-crypto-iv (eseqiv.ko and chainiv.ko).
Signed-off-by: Lars Hjersted <lars@hjersted.com> SVN-Revision: 26814
Diffstat (limited to 'package/kernel/modules/crypto.mk')
-rw-r--r--package/kernel/modules/crypto.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index 5aa954900d..f31331e326 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -28,6 +28,13 @@ CRYPTOMGR_MODULES = \
MANAGER2=cryptomgr \
BLKCIPHER2=crypto_blkcipher
+CRYPTOIPSEC_MODULES = \
+ WORKQUEUE=crypto_wq \
+ RNG2=rng \
+ RNG2=krng \
+ BLKCIPHER2=eseqiv \
+ BLKCIPHER2=chainiv
+
crypto_confvar=CONFIG_CRYPTO_$(word 1,$(subst =,$(space),$(1)))
crypto_file=$(if $(findstring y,$($(call crypto_confvar,$(1)))),,$(LINUX_DIR)/crypto/$(word 2,$(subst =,$(space),$(1))).ko)
crypto_name=$(if $(findstring y,$($(call crypto_confvar,$(1)))),,$(word 2,$(subst =,$(space),$(1))))
@@ -108,6 +115,15 @@ define KernelPackage/crypto-iv
endef
$(eval $(call KernelPackage,crypto-iv))
+define KernelPackage/crypto-ipsec
+ TITLE:=IPSEC CryptoAPI modules
+ KCONFIG:=$(foreach mod,$(CRYPTOIPSEC_MODULES),$(call crypto_confvar,$(mod)))
+ FILES:=$(foreach mod,$(CRYPTOIPSEC_MODULES),$(call crypto_file,$(mod)))
+ AUTOLOAD:=$(call AutoLoad,09,$(foreach mod,$(CRYPTOIPSEC_MODULES),$(call crypto_name,$(mod))))
+ $(call AddDepends/crypto)
+endef
+$(eval $(call KernelPackage,crypto-ipsec))
+
define KernelPackage/crypto-hw-padlock
TITLE:=VIA PadLock ACE with AES/SHA hw crypto module
DEPENDS:=+kmod-crypto-aes