summaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/crypto.mk
diff options
context:
space:
mode:
authorAndy Boyett <agb@openwrt.org>2009-10-05 17:05:43 +0000
committerAndy Boyett <agb@openwrt.org>2009-10-05 17:05:43 +0000
commit333be1a4d766901a3808e110655c5108cc067439 (patch)
tree5d88015711b4d93d39763d298a195a7a81591193 /package/kernel/modules/crypto.mk
parentc85a89348fced01483dd5ddebcb7e2293b33901d (diff)
downloadmaster-31e0f0ae-333be1a4d766901a3808e110655c5108cc067439.tar.gz
master-31e0f0ae-333be1a4d766901a3808e110655c5108cc067439.tar.bz2
master-31e0f0ae-333be1a4d766901a3808e110655c5108cc067439.zip
modules/crypto: package AMCC ppc4xx hardware crypto driver
SVN-Revision: 17906
Diffstat (limited to 'package/kernel/modules/crypto.mk')
-rw-r--r--package/kernel/modules/crypto.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index e2361a26c0..f75ebe9f81 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -139,6 +139,25 @@ endef
$(eval $(call KernelPackage,crypto-hw-ixp4xx))
+define KernelPackage/crypto-hw-ppc4xx
+ SUBMENU:=$(CRYPTO_MENU)
+ TITLE:=AMCC PPC4xx hardware crypto module
+ DEPENDS:= \
+ @TARGET_ppc40x||TARGET_ppc44x +kmod-crypto-core
+ KCONFIG:= \
+ CONFIG_CRYPTO_HW=y \
+ CONFIG_CRYPTO_DEV_PPC4XX
+ FILES:=$(LINUX_DIR)/drivers/crypto/amcc/crypto4xx.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,90,crypto4xx)
+endef
+
+define KernelPackage/crypto-hw-ppc4xx/description
+ Kernel support for the AMCC PPC4xx HW crypto engine.
+endef
+
+$(eval $(call KernelPackage,crypto-hw-ppc4xx))
+
+
define KernelPackage/crypto-aes
SUBMENU:=$(CRYPTO_MENU)
TITLE:=AES cipher CryptoAPI module