summaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/patches/000-fix_kconfig.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-11 15:02:47 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-11 15:02:47 +0000
commit1e5b7c17b031359a37ed7772b92cc98aaaeac727 (patch)
tree5e2a88ef16da6f5c7c3b74ef607e5ba892252d5b /package/kernel/mac80211/patches/000-fix_kconfig.patch
parentee1e8c2f2df3b03ef89e5a8b31ae9e2f9907ade1 (diff)
downloadmaster-31e0f0ae-1e5b7c17b031359a37ed7772b92cc98aaaeac727.tar.gz
master-31e0f0ae-1e5b7c17b031359a37ed7772b92cc98aaaeac727.tar.bz2
master-31e0f0ae-1e5b7c17b031359a37ed7772b92cc98aaaeac727.zip
mac80211: update to wireless-testing 2015-03-09
Based on patch by Bryan Forbes <bryan@reigndropsfall.net> Also update mt76 to update for API changes Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 44655
Diffstat (limited to 'package/kernel/mac80211/patches/000-fix_kconfig.patch')
-rw-r--r--package/kernel/mac80211/patches/000-fix_kconfig.patch12
1 files changed, 5 insertions, 7 deletions
diff --git a/package/kernel/mac80211/patches/000-fix_kconfig.patch b/package/kernel/mac80211/patches/000-fix_kconfig.patch
index 662608ed40..3987aae4f5 100644
--- a/package/kernel/mac80211/patches/000-fix_kconfig.patch
+++ b/package/kernel/mac80211/patches/000-fix_kconfig.patch
@@ -1,16 +1,14 @@
--- a/kconf/Makefile
+++ b/kconf/Makefile
-@@ -1,10 +1,10 @@
+@@ -1,9 +1,9 @@
-CFLAGS=-Wall -Wmissing-prototypes -Wstrict-prototypes -O2 -fomit-frame-pointer
+CFLAGS=-Wall -Wmissing-prototypes -Wstrict-prototypes -O2 -fomit-frame-pointer -DKBUILD_NO_NLS
LXDIALOG := lxdialog/checklist.o lxdialog/inputbox.o lxdialog/menubox.o lxdialog/textbox.o lxdialog/util.o lxdialog/yesno.o
conf: conf.o zconf.tab.o
--mconf: LDFLAGS = -Wl,--add-needed $(shell ./lxdialog/check-lxdialog.sh -ldflags $(CC))
--mconf: CFLAGS += -DCURSES_LOC="<ncurses.h>" -DLOCALE
-+mconf: LDFLAGS = $(shell ./lxdialog/check-lxdialog.sh -ldflags $(CC))
-+mconf: CFLAGS += -DCURSES_LOC="<ncurses.h>"
- mconf: mconf.o zconf.tab.o $(LXDIALOG)
+-mconf_CFLAGS := $(shell ./lxdialog/check-lxdialog.sh -ccflags) -DLOCALE
++mconf_CFLAGS := $(shell ./lxdialog/check-lxdialog.sh -ccflags)
+ mconf_LDFLAGS := $(shell ./lxdialog/check-lxdialog.sh -ldflags $(CC))
+ mconf: CFLAGS += $(mconf_CFLAGS)
- .PHONY: clean