summaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-23 09:36:03 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-23 09:36:03 +0000
commitecfd245133e9b5bf4c9f0bd827ba20125ab693a2 (patch)
tree911b8560922c630fd7ea427ed625928d27d380c7 /package/kernel/mac80211/Makefile
parentecdce239a54b7a4c4aa760a659c13642e1817326 (diff)
downloadmaster-31e0f0ae-ecfd245133e9b5bf4c9f0bd827ba20125ab693a2.tar.gz
master-31e0f0ae-ecfd245133e9b5bf4c9f0bd827ba20125ab693a2.tar.bz2
master-31e0f0ae-ecfd245133e9b5bf4c9f0bd827ba20125ab693a2.zip
mac80211: disable ipw2x00 for big endian targets
The ipw2x00 drivers assume that the system they are running is little endian, and access everything in native byte order. When run on a big endian system, everything breaks apart. Since fixing this is non trivial on a first glance, disable them for big endian targets. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46708
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 6afef107cb..04dfd3b4ea 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -719,7 +719,7 @@ endef
define KernelPackage/net-libipw
$(call KernelPackage/mac80211/Default)
TITLE:=libipw for ipw2100 and ipw2200
- DEPENDS:=@PCI_SUPPORT +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-michael-mic +kmod-lib80211 +kmod-cfg80211 +@DRIVER_WEXT_SUPPORT
+ DEPENDS:=@PCI_SUPPORT +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-michael-mic +kmod-lib80211 +kmod-cfg80211 +@DRIVER_WEXT_SUPPORT @!BIG_ENDIAN
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ipw2x00/libipw.ko
AUTOLOAD:=$(call AutoProbe,libipw)
endef