summaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-10 16:37:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-10 16:37:01 +0000
commita960fcef292c805b1d7a8fe8a9f6995ca7f4931b (patch)
tree9ad261489d380052f9bde8f69e2886801f7e8fdd /package/kernel/mac80211/Makefile
parent805c40351e34eb8fd9413cbf0a2556b172d60a0a (diff)
downloadmaster-31e0f0ae-a960fcef292c805b1d7a8fe8a9f6995ca7f4931b.tar.gz
master-31e0f0ae-a960fcef292c805b1d7a8fe8a9f6995ca7f4931b.tar.bz2
master-31e0f0ae-a960fcef292c805b1d7a8fe8a9f6995ca7f4931b.zip
mac80211: move b43legacy firmware to a separate package
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48184
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile53
1 files changed, 1 insertions, 52 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index c0a3b3b240..e096f7555f 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -313,12 +313,6 @@ ifneq ($(CONFIG_B43_OPENFIRMWARE),)
endif
-PKG_B43_FWV3_NAME:=wl_apsta
-PKG_B43_FWV3_VERSION:=3.130.20.0
-PKG_B43_FWV3_SOURCE:=$(PKG_B43_FWV3_NAME)-$(PKG_B43_FWV3_VERSION).o
-PKG_B43_FWV3_SOURCE_URL:=http://downloads.openwrt.org/sources/
-PKG_B43_FWV3_MD5SUM:=e08665c5c5b66beb9c3b2dd54aa80cb3
-
define Download/b43
FILE:=$(PKG_B43_FWV4_SOURCE)
URL:=$(PKG_B43_FWV4_SOURCE_URL)
@@ -326,14 +320,6 @@ define Download/b43
endef
$(eval $(call Download,b43))
-define Download/b43legacy
- FILE:=$(PKG_B43_FWV3_SOURCE)
- URL:=$(PKG_B43_FWV3_SOURCE_URL)
- MD5SUM:=$(PKG_B43_FWV3_MD5SUM)
-endef
-$(eval $(call Download,b43legacy))
-
-
define KernelPackage/b43
$(call KernelPackage/mac80211/Default)
TITLE:=Broadcom 43xx wireless support
@@ -584,41 +570,12 @@ define KernelPackage/b43legacy
URL:=https://wireless.wiki.kernel.org/en/users/drivers/b43
KCONFIG:= \
CONFIG_HW_RANDOM=y
- DEPENDS+= +kmod-mac80211 +!(TARGET_brcm47xx||TARGET_brcm63xx):kmod-ssb
+ DEPENDS+= +kmod-mac80211 +!(TARGET_brcm47xx||TARGET_brcm63xx):kmod-ssb +b43legacy-firmware
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/broadcom/b43legacy/b43legacy.ko
AUTOLOAD:=$(call AutoProbe,b43legacy)
MENU:=1
endef
-define KernelPackage/b43legacy/config
- if PACKAGE_kmod-b43legacy
-
- config B43LEGACY_FW_SQUASH
- bool "Remove unnecessary firmware files"
- default y
- help
- This options allows you to remove unnecessary b43legacy firmware files
- from the final rootfs image. This can reduce the rootfs size by
- up to 50k.
-
- If unsure, say Y.
-
- config B43LEGACY_FW_SQUASH_COREREVS
- string "Core revisions to include"
- depends on B43LEGACY_FW_SQUASH
- default "1,2,3,4"
- help
- This is a comma seperated list of core revision numbers.
-
- Example (keep files for rev4 only):
- 4
-
- Example (keep files for rev2 and rev4):
- 2,4
-
- endif
-endef
-
define KernelPackage/b43legacy/description
Kernel module for Broadcom 43xx-legacy wireless support (mac80211 stack) new
endef
@@ -1746,14 +1703,6 @@ ifneq ($(CONFIG_B43_FW_SQUASH),)
endif
endef
-define KernelPackage/b43legacy/install
- $(INSTALL_DIR) $(1)/lib/firmware/
- b43-fwcutter --unsupported -w $(1)/lib/firmware/ $(DL_DIR)/$(PKG_B43_FWV3_SOURCE)
-ifneq ($(CONFIG_B43LEGACY_FW_SQUASH),)
- b43-fwsquash.py "G" "$(CONFIG_B43LEGACY_FW_SQUASH_COREREVS)" "$(1)/lib/firmware/b43legacy"
-endif
-endef
-
define KernelPackage/brcmsmac/install
$(INSTALL_DIR) $(1)/lib/firmware/brcm
ifeq ($(CONFIG_BRCMSMAC_USE_FW_FROM_WL),y)