summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-06-02 12:45:05 +0000
committerJohn Crispin <john@openwrt.org>2014-06-02 12:45:05 +0000
commitf91dd34ee9a3d412c9dc7ff523de56a4f5a7f66a (patch)
tree55883b7680ef4adeadbd0e5b03627938aa6cb4f7 /package/kernel/linux
parent35d3c91c863b4a66acd07daf740fbbaf702d4b19 (diff)
downloadmaster-31e0f0ae-f91dd34ee9a3d412c9dc7ff523de56a4f5a7f66a.tar.gz
master-31e0f0ae-f91dd34ee9a3d412c9dc7ff523de56a4f5a7f66a.tar.bz2
master-31e0f0ae-f91dd34ee9a3d412c9dc7ff523de56a4f5a7f66a.zip
kernel: Fix xen domU kmod-xen-kbd package
modified version of http://patchwork.openwrt.org/patch/5526/ Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 40941
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/virtual.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/virtual.mk b/package/kernel/linux/modules/virtual.mk
index e1bbe3f439..3a1fe006fa 100644
--- a/package/kernel/linux/modules/virtual.mk
+++ b/package/kernel/linux/modules/virtual.mk
@@ -142,8 +142,9 @@ $(eval $(call KernelPackage,xen-fbdev))
define KernelPackage/xen-kbddev
SUBMENU:=$(VIRTUAL_MENU)
TITLE:=Xen virtual keyboard and mouse
- DEPENDS:=@TARGET_x86_xen_domu
- KCONFIG:=CONFIG_XEN_KBDDEV_FRONTEND
+ DEPENDS:=@TARGET_x86_xen_domu +kmod-input-core
+ KCONFIG:=CONFIG_INPUT_MISC=y \
+ CONFIG_INPUT_XEN_KBDDEV_FRONTEND
FILES:=$(LINUX_DIR)/drivers/input/xen-kbdfront.ko
AUTOLOAD:=$(call AutoLoad,08,xen-kbdfront)
endef